summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilydjwg2015-07-25 13:11:48 +0800
committerlilydjwg2015-07-25 13:11:48 +0800
commitca81c6579a5af5fc30f39161708881e19df6859d (patch)
treeb8bfd98e949520c219e92920b61be37b8603d2dd
downloadaur-ca81c6579a5af5fc30f39161708881e19df6859d.tar.gz
import from AUR3
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD38
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..39ec4f74f5e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = systemtap-git
+ pkgdesc = SystemTap provides free software (GPL) infrastructure to simplify the gathering of information about the running Linux system.
+ pkgver = 2.3.1539.g00b943a
+ pkgrel = 1
+ url = http://sourceware.org/systemtap/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = elfutils
+ depends = nss
+ depends = python2
+ depends = avahi
+ optdepends = sqlite3
+ optdepends = linux-fedora: for debug enabled kernel
+ optdepends = linux-lily-debug: for debug enabled kernel
+ provides = systemtap=2.3
+ conflicts = systemtap
+ source = git+git://github.com/fche/systemtap.git
+ md5sums = SKIP
+
+pkgname = systemtap-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..52a103dd3a0f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: lilydjwg <lilydjwg@gmail.com>
+pkgname=systemtap-git
+pkgver=2.3.1539.g00b943a
+pkgrel=1
+pkgdesc="SystemTap provides free software (GPL) infrastructure to simplify the gathering of information about the running Linux system."
+url="http://sourceware.org/systemtap/"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('elfutils' 'nss' 'python2' 'avahi')
+makedepends=('git')
+optdepends=('sqlite3' 'linux-fedora: for debug enabled kernel' 'linux-lily-debug: for debug enabled kernel')
+provides=(systemtap=2.3)
+conflicts=(systemtap)
+_gitroot=git://github.com/fche/systemtap.git
+_gitname=systemtap
+source=("git+$_gitroot")
+md5sums=(SKIP)
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git describe | sed 's/release-//;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ msg "Starting make..."
+
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var --libexecdir=/usr/lib
+ make
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ make DESTDIR="${pkgdir}" install
+ mv "${pkgdir}"/var/run "${pkgdir}"
+ sed -i 's=#!/usr/bin/python.*=#!/usr/bin/python2=' "${pkgdir}/usr/bin/dtrace"
+}