summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0x472017-04-20 17:50:08 +0200
committer0x472017-04-20 17:50:08 +0200
commit594fbfb5621c5a646dd962aacf35dcf1df795544 (patch)
tree16da86bab867763d9fe5dd0f17f01b92c5e38a83
downloadaur-594fbfb5621c5a646dd962aacf35dcf1df795544.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..71dcf8d13785
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = systray-mdstat
+ pkgdesc = System tray icon indicating the state of local Linux Software (MD) RAID by checking /proc/mdstat periodically
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/xtaran/systray-mdstat
+ arch = any
+ license = GPL3
+ depends = perl>=5.10
+ depends = perl-gtk3
+ depends = perl-glib-object-introspection
+ depends = perl-file-sharedir
+ depends = perl-try-tiny
+ optdepends = mdadm: making this tool functional
+ source = https://github.com/xtaran/systray-mdstat/releases/download/1.0.1/systray-mdstat-1.0.1.tar.gz
+ sha256sums = 4cac16618e8af65b963a969c16d3f19eae251b0773fdf95df74c2670413deb93
+
+pkgname = systray-mdstat
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ada7b9167b22
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: 0x47
+pkgname=systray-mdstat
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="System tray icon indicating the state of local Linux Software (MD) RAID by checking /proc/mdstat periodically"
+arch=(any)
+url="https://github.com/xtaran/systray-mdstat"
+license=('GPL3')
+groups=()
+depends=("perl>=5.10" "perl-gtk3" "perl-glib-object-introspection" "perl-file-sharedir" "perl-try-tiny")
+optdepends=("mdadm: making this tool functional")
+install=
+source=("https://github.com/xtaran/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=(4cac16618e8af65b963a969c16d3f19eae251b0773fdf95df74c2670413deb93)
+
+package() {
+ src="${srcdir}/${pkgname}-${pkgver}"
+
+ install -dm755 $pkgdir/usr/share/perl5/vendor_perl/auto/share/dist/systray-mdstat
+ install -Dm644 $src/share/* $pkgdir/usr/share/perl5/vendor_perl/auto/share/dist/systray-mdstat/
+
+ install -dm755 $pkgdir/usr/bin
+ install -Dm755 $src/bin/systray-mdstat $pkgdir/usr/bin/
+
+ if [ -z "$XDG_CONFIG_DIRS" ]; then
+ XDG_CONFIG_DIRS="/etc/xdg"
+ fi
+ install -dm755 $pkgdir/$XDG_CONFIG_DIRS/autostart
+ install -Dm644 $src/systray-mdstat.desktop $pkgdir/$XDG_CONFIG_DIRS/autostart/
+}