summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhillip Smith2015-06-02 12:23:01 +1000
committerPhillip Smith2015-06-02 12:23:01 +1000
commitbfd08cdeb86345075514bdc84f3444353e77668e (patch)
treed5579b870b9f41b825054c5661b455521b677e7e
downloadaur-bfd08cdeb86345075514bdc84f3444353e77668e.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD68
-rw-r--r--sysusage.install12
4 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eccb9f8fe1b3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = sysusage
+ pkgdesc = Monitor your systems informations and generate periodical graph reports using rrdtool. All reports are shown throught a web interface.
+ pkgver = 5.4
+ pkgrel = 2
+ url = http://sysusage.darold.net/
+ install = sysusage.install
+ arch = any
+ license = GPL3
+ depends = inetutils
+ depends = rrdtool
+ depends = sysstat
+ depends = perl
+ depends = perl-proc-queue
+ depends = procps-ng
+ backup = etc/sysusage.cfg
+ source = http://downloads.sourceforge.net/sysusage/sysusage-5.4.tar.gz
+ md5sums = c664de8983bc86ec7f0c09831974e6b6
+
+pkgname = sysusage
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1931b0e9bd7e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/sysusage-*.pkg.tar.xz
+/sysusage-*.tar.gz
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b239fe1fe7b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Maintainer: Phillip Smith <fukawi2@NO-SPAM.gmail.com>
+# http://github.com/fukawi2/aur-packages
+
+### I AM ONLY THE PACKAGER, NOT THE DEVELOPER
+### Please ask support questions about this software in one of:
+### 1) The AUR comments; OR
+### 2) Upstream forums/maillist etc; OR
+### 3) The ArchLinux forums
+### I do not always know enough about the software itself, or don't have the
+### time to promptly respond to direct emails.
+### If you have found a problem with the package/PKGBUILD (as opposed to
+### the software) then please do email me or post an AUR comment.
+
+pkgname=sysusage
+pkgver=5.4
+pkgrel=2
+pkgdesc="Monitor your systems informations and generate periodical graph reports using rrdtool. All reports are shown throught a web interface."
+arch=('any')
+url="http://sysusage.darold.net/"
+license=('GPL3')
+depends=('inetutils' 'rrdtool' 'sysstat' 'perl' 'perl-proc-queue' 'procps-ng')
+backup=('etc/sysusage.cfg')
+install="$pkgname.install"
+source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+md5sums=('c664de8983bc86ec7f0c09831974e6b6')
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ perl Makefile.PL \
+ BINDIR=/usr/bin \
+ CONFDIR=/etc \
+ PIDDIR=/var/run \
+ BASEDIR=/var/lib/$pkgname \
+ HTMLDIR=/srv/http/$pkgname \
+ MANDIR=/usr/share/man/man1 \
+ DOCDIR=/usr/share/doc/$pkgname
+
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ install -dm755 "$pkgdir"/var/lib/sysusage
+
+ install -Dm644 Sar.pm "$pkgdir"/usr/share/perl5/vendor_perl/SysUsage/Sar.pm
+ install -Dm644 sysusage.cfg "$pkgdir"/etc/sysusage.cfg
+ install -Dm755 bin/sysusage "$pkgdir"/usr/bin/sysusage
+ install -Dm755 bin/sysusagegraph "$pkgdir"/usr/bin/sysusagegraph
+ install -Dm755 bin/sysusagewarn "$pkgdir"/usr/bin/sysusagewarn
+ install -Dm644 resources/sysusage-logo.png "$pkgdir"/srv/http/sysusage/sysusage-logo.png
+ install -Dm644 resources/sysusage.css "$pkgdir"/srv/http/sysusage/sysusage.css
+ install -Dm644 resources/sysusage.js "$pkgdir"/srv/http/sysusage/sysusage.js
+ install -Dm644 resources/sysusage_arrow.png "$pkgdir"/srv/http/sysusage/sysusage_arrow.png
+ install -Dm644 resources/favicon.ico "$pkgdir"/srv/http/sysusage/favicon.ico
+ install -Dm644 doc/sysusage.1 "$pkgdir"/usr/share/man/man1/sysusage.1
+ install -Dm644 README "$pkgdir"/usr/share/doc/sysusage/README
+ install -Dm644 ChangeLog "$pkgdir"/usr/share/doc/sysusage/ChangeLog
+ install -Dm755 plugins/plugin-sample1.pl "$pkgdir"/usr/share/doc/sysusage/plugins/plugin-sample1.pl
+ install -Dm755 plugins/plugin-sample2.pl "$pkgdir"/usr/share/doc/sysusage/plugins/plugin-sample2.pl
+
+ # install sysusagejqgraph as per request from @cerb
+ install -Dm755 bin/sysusagejqgraph "$pkgdir"/usr/bin/sysusagejqgraph
+ tar xzf resources/jqplot-sysusage.tar.gz --directory "$pkgdir"/srv/http/sysusage
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/sysusage.install b/sysusage.install
new file mode 100644
index 000000000000..3dc08d7ec8ae
--- /dev/null
+++ b/sysusage.install
@@ -0,0 +1,12 @@
+## arg 1: the new package version
+post_install() {
+ cat << EOM
+==> sysusage: Now you can run sysusage into you crontab as follow:
+==> sysusage:
+==> sysusage: */1 * * * * /usr/bin/sysusage > /dev/null 2>&1
+==> sysusage: */5 * * * * /usr/bin/sysusagegraph > /dev/null 2>&1
+==> sysusage:
+==> sysusage: If you need to monitor your host under the minute, you can use DEAMON mode.
+==> sysusage: See /usr/share/doc/sysusage/README file.
+EOM
+}