summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormegadrivers2015-06-09 18:44:56 +0200
committermegadrivers2015-06-09 18:44:56 +0200
commit772e71ad716f4a243aabc03e7bef487f094666d2 (patch)
tree856c56bcc74fe78e44b6a1c2066215b436cbc707
downloadaur-772e71ad716f4a243aabc03e7bef487f094666d2.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--Makefile.patch31
-rw-r--r--PKGBUILD25
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..30d8dad36788
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = sz81
+ pkgdesc = Sinclair ZX80/ZX81 emulator
+ pkgver = 2.1.7
+ pkgrel = 1
+ url = http://sz81.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = sdl
+ source = http://downloads.sourceforge.net/sourceforge/sz81/sz81-2.1.7-source.tar.gz
+ source = Makefile.patch
+ md5sums = e0ec83d076793e6275dd58d22139eabe
+ md5sums = ee08235fbd63a49b69f8572b01e810b7
+
+pkgname = sz81
+
diff --git a/Makefile.patch b/Makefile.patch
new file mode 100644
index 000000000000..3346ea851b12
--- /dev/null
+++ b/Makefile.patch
@@ -0,0 +1,31 @@
+--- Makefile 2011-02-12 23:28:52.000000000 +0100
++++ Makefile.new 2011-02-16 00:49:41.333334622 +0100
+@@ -1,9 +1,9 @@
+ # Comment/uncomment these to choose an installation destination
+ # System wide installation
+-#PREFIX?=/usr/local
+-#BINDIR?=$(PREFIX)/bin
+-#DOCDIR?=$(PREFIX)/share/doc/$(TARGET)
+-#PACKAGE_DATA_DIR?=$(PREFIX)/share/$(TARGET)
++PREFIX?=/usr
++BINDIR?=$(PREFIX)/bin
++DOCDIR?=$(PREFIX)/share/doc/$(TARGET)
++PACKAGE_DATA_DIR?=$(PREFIX)/share/$(TARGET)
+
+ # Local installation within your home folder
+ #PREFIX?=$(HOME)/Games/$(TARGET)
+@@ -12,10 +12,10 @@
+ #PACKAGE_DATA_DIR?=$(PREFIX)/data
+
+ # Run from current folder i.e. no installation
+-PREFIX?=.
+-BINDIR?=$(PREFIX)
+-DOCDIR?=$(PREFIX)
+-PACKAGE_DATA_DIR?=$(PREFIX)/data
++#PREFIX?=.
++#BINDIR?=$(PREFIX)
++#DOCDIR?=$(PREFIX)
++#PACKAGE_DATA_DIR?=$(PREFIX)/data
+
+ # For sz81 OSS_SOUND_SUPPORT is now synonymous with SDL_SOUND_SUPPORT.
+ # Comment this out if you don't want sound support.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4ee7f3be216
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: megadriver <megadriver at gmx dot com>
+
+pkgname=sz81
+pkgver=2.1.7
+pkgrel=1
+pkgdesc="Sinclair ZX80/ZX81 emulator"
+arch=('i686' 'x86_64')
+url="http://sz81.sourceforge.net/"
+license=("GPL2")
+depends=('sdl')
+source=(http://downloads.sourceforge.net/sourceforge/sz81/sz81-$pkgver-source.tar.gz
+ Makefile.patch)
+md5sums=('e0ec83d076793e6275dd58d22139eabe'
+ 'ee08235fbd63a49b69f8572b01e810b7')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ patch -p0 < $srcdir/Makefile.patch
+ make || return 1
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make PREFIX=$pkgdir/usr install
+}