summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDX372017-01-25 22:27:25 +0700
committerDX372017-01-25 22:27:25 +0700
commit0b4a32c7290aa9263d4336d780e24732d579dc53 (patch)
tree7942c864c94259398de539884e82bea75e8b305a
downloadaur-0b4a32c7290aa9263d4336d780e24732d579dc53.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
-rw-r--r--brcmfmac43340-sdio.txtbin0 -> 2862 bytes
-rw-r--r--t200ta-wifi.install29
4 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b4af45050302
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = t200ta-wifi
+ pkgdesc = Wi-Fi lib for ASUS T200TA (and possibly other Bay Trail devices)
+ pkgver = r1
+ pkgrel = 1
+ url = https://github.com/DX37/T200TA
+ install = t200ta-wifi.install
+ arch = any
+ license = GPL
+ optdepends = networkmanager: awesome internet connections manager
+ optdepends = network-manager-applet: GUI and tray icon for networkmanager
+ source = https://github.com/DX37/T200TA/raw/master/libs/brcmfmac43340-sdio.txt
+ md5sums = fd635836716e71a543b2c134d01e0613
+
+pkgname = t200ta-wifi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36adfe052108
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Maxim Kurnosenko <asusx2@mail.ru>
+
+pkgname=t200ta-wifi
+pkgver=r1
+pkgrel=1
+pkgdesc="Wi-Fi lib for ASUS T200TA (and possibly other Bay Trail devices)"
+arch=('any')
+url="https://github.com/DX37/T200TA"
+license=('GPL')
+optdepends=('networkmanager: awesome internet connections manager'
+ 'network-manager-applet: GUI and tray icon for networkmanager')
+install=$pkgname.install
+source=("brcmfmac43340-sdio.txt")
+md5sums=('fd635836716e71a543b2c134d01e0613')
+
+package() {
+ # Just installing needed file
+ install -Dm644 brcmfmac43340-sdio.txt "$pkgdir"/usr/lib/firmware/brcm/brcmfmac43340-sdio.txt
+}
diff --git a/brcmfmac43340-sdio.txt b/brcmfmac43340-sdio.txt
new file mode 100644
index 000000000000..988656d980ee
--- /dev/null
+++ b/brcmfmac43340-sdio.txt
Binary files differ
diff --git a/t200ta-wifi.install b/t200ta-wifi.install
new file mode 100644
index 000000000000..a11953a065c4
--- /dev/null
+++ b/t200ta-wifi.install
@@ -0,0 +1,29 @@
+pre_install() {
+ # preparing module
+ rmmod brcmfmac
+}
+
+post_install() {
+ # restarting module after needed file installing
+ modprobe brcmfmac
+}
+
+pre_upgrade() {
+ # preparing module
+ rmmod brcmfmac
+}
+
+post_upgrade() {
+ # restarting module after needed file updating
+ modprobe brcmfmac
+}
+
+pre_remove() {
+ # since you don't need wi-fi, I guess I can remove module?
+ rmmod brcmfmac
+}
+
+post_remove() {
+ # enjoy your wi-fi-less device :D
+ modprobe brcmfmac
+}