summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpiotr2019-01-16 01:10:19 +0100
committerpiotr2019-01-16 01:10:19 +0100
commit2f8e6530242408f8b65c015056bbbef37abcf156 (patch)
tree12281e02191b837ccaa344b8e83fea91fadc1568
parentaef4d7623ce998a77b5791c67667f2396110a89b (diff)
downloadaur-2f8e6530242408f8b65c015056bbbef37abcf156.tar.gz
New --paswitch command; fixes to --volume toggle
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f754dddb4364..a891fd44af67 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = t2ec
pkgdesc = Scripts to display info icons and controls in Tint2 or other panels
- pkgver = 1.1
- pkgrel = 3
+ pkgver = 1.2
+ pkgrel = 1
url = https://github.com/nwg-piotr/tint2-executors
arch = x86_64
license = GPL3
@@ -11,11 +11,13 @@ pkgbase = t2ec
depends = alsa-utils
depends = wireless_tools
depends = wget
+ depends = pulseaudio
+ depends = pulseaudio-alsa
optdepends = light: for machines not handling xbacklight
optdepends = rof-git: for running mouse events commands as single instances
optdepends = zenity: for volume and brightness slider box
- source = https://github.com/nwg-piotr/t2ec/archive/v1.1-3.tar.gz
- md5sums = a98ea36917c09da167f4c2236211f452
+ source = https://github.com/nwg-piotr/t2ec/archive/v1.2.tar.gz
+ md5sums = 9c8bd0864023bccea983a0eb6eb6800d
pkgname = t2ec
diff --git a/PKGBUILD b/PKGBUILD
index 8111b34b4092..5782e60efa62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
# Maintainer: Piotr Miller <nwg.piotr@gmail.com>
pkgname=('t2ec')
-pkgver=1.1
-pkgrel=3
+pkgver=1.2
+pkgrel=1
pkgdesc="Scripts to display info icons and controls in Tint2 or other panels"
arch=('x86_64')
url="https://github.com/nwg-piotr/tint2-executors"
license=('GPL3')
-depends=('python' 'acpi' 'xorg-xbacklight' 'alsa-utils' 'wireless_tools' 'wget')
+depends=('python' 'acpi' 'xorg-xbacklight' 'alsa-utils' 'wireless_tools' 'wget' 'pulseaudio' 'pulseaudio-alsa')
optdepends=('light: for machines not handling xbacklight'
'rof-git: for running mouse events commands as single instances'
'zenity: for volume and brightness slider box')
-source=("https://github.com/nwg-piotr/t2ec/archive/v1.1-3.tar.gz")
+source=("https://github.com/nwg-piotr/t2ec/archive/v1.2.tar.gz")
-md5sums=('a98ea36917c09da167f4c2236211f452')
+md5sums=('9c8bd0864023bccea983a0eb6eb6800d')
package() {
- install -D -t "$pkgdir"/usr/lib/"$pkgname" "$pkgname"-"$pkgver"-"$pkgrel"/scripts-arch/*.sh
- install -D -t "$pkgdir"/usr/lib/"$pkgname" "$pkgname"-"$pkgver"-"$pkgrel"/scripts-arch/*.py
- install -D -t "$pkgdir"/usr/bin "$pkgname"-"$pkgver"-"$pkgrel"/scripts-arch/t2ec
- install -D -t "$pkgdir"/usr/share/"$pkgname" "$pkgname"-"$pkgver"-"$pkgrel"/images/*.svg
- install -D -t "$pkgdir"/usr/share/tint2 "$pkgname"-"$pkgver"-"$pkgrel"/configs-arch/*.tint2rc
+ install -D -t "$pkgdir"/usr/lib/"$pkgname" "$pkgname"-"$pkgver"/scripts-arch/*.sh
+ install -D -t "$pkgdir"/usr/lib/"$pkgname" "$pkgname"-"$pkgver"/scripts-arch/*.py
+ install -D -t "$pkgdir"/usr/bin "$pkgname"-"$pkgver"/scripts-arch/t2ec
+ install -D -t "$pkgdir"/usr/share/"$pkgname" "$pkgname"-"$pkgver"/images/*.svg
+ install -D -t "$pkgdir"/usr/share/tint2 "$pkgname"-"$pkgver"/configs-arch/*.tint2rc
}