summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrealgagu2020-12-09 13:06:42 -0500
committerfrealgagu2020-12-09 13:06:42 -0500
commit1767dd531f85e08a4690dacc9f818cf03d2f5955 (patch)
tree2bdc48e444f55dbf94b368def5df0f44393e6970
parent7f61a8e95d6ffd38c83ebc118793fd288794d81a (diff)
downloadaur-1767dd531f85e08a4690dacc9f818cf03d2f5955.tar.gz
Adding wrapped_lines patch.
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD53
-rw-r--r--libpng15.patch8
-rw-r--r--wrapped_lines.patch13
5 files changed, 66 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e8b91d5d78f..eeea547b9596 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,25 @@
pkgbase = t4kcommon
- pkgdesc = Common library for code shared by TuxType and TuxMath
+ pkgdesc = A library of code shared between tuxmath and tuxtype.
pkgver = 0.1.1
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/tux4kids/t4kcommon
arch = i686
arch = x86_64
license = GPL
- makedepends = make
+ depends = librsvg
depends = sdl_image
depends = sdl_mixer
- depends = sdl_pango
depends = sdl_net
- depends = librsvg
+ depends = sdl_pango
options = !docs
- source = https://github.com/tux4kids/t4kcommon/archive/upstream/0.1.1.tar.gz
+ source = t4kcommon-0.1.1.tar.gz::https://github.com/tux4kids/t4kcommon/archive/upstream/0.1.1.tar.gz
source = libpng15.patch
source = https://sources.debian.org/data/main/t/t4kcommon/0.1.1-6/debian/patches/916060_bugfix.patch
+ source = wrapped_lines.patch
sha256sums = be4cadbcf2728ed6efb1c71e96c209184a7829b65af3625d9410a29fb2fd775a
- sha256sums = 9a778a6bbe6f1c95b5ad1418a35bb41dbdbe3afb6520745eb9bd34dfa7a27dbf
+ sha256sums = e2998909bed025becbe52969eb53b40eede05e75285b400cbafac6207cf82c3f
sha256sums = 1d5bb9a9cf809f26508e4611fb564e050b554036a679ec28b79827785a3f46c8
+ sha256sums = 0643e9eada6fdba1a295798ea3d09be71cafbf5af6ba132dd15a4f372d58dcf3
pkgname = t4kcommon
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d01013b9e7eb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+t4kcommon-*.pkg.tar.zst
+t4kcommon-*.pkg.tar.xz
+t4kcommon-*.tar.gz
+t4kcommon-*.log
+916060_bugfix.patch
+PKGBUILD-namcap.log
+t4kcommon-upstream-*/
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
index bc2897fae009..2483fc9cf316 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,47 @@
-# Maintainer: Alexandre Moine < nobrakal at moine dot org >
+# Maintainer: Fredy GarcĂ­a <frealgagu at gmail dot com>
+# Contributor: Alexandre Moine < nobrakal at moine dot org >
# Contributor: Tasos Latsas < tlatsas2000 at gmail dot com >
pkgname=t4kcommon
pkgver=0.1.1
-pkgrel=4
-pkgdesc="Common library for code shared by TuxType and TuxMath"
-arch=('i686' 'x86_64')
-url="https://github.com/tux4kids/t4kcommon"
-license=('GPL')
-depends=('sdl_image' 'sdl_mixer' 'sdl_pango' 'sdl_net' 'librsvg')
-makedepends=('make')
-options=('!docs')
-replace=('t4k_common')
-source=("https://github.com/tux4kids/$pkgname/archive/upstream/${pkgver}.tar.gz"
- "libpng15.patch"
- https://sources.debian.org/data/main/t/t4kcommon/0.1.1-6/debian/patches/916060_bugfix.patch)
-sha256sums=('be4cadbcf2728ed6efb1c71e96c209184a7829b65af3625d9410a29fb2fd775a'
- '9a778a6bbe6f1c95b5ad1418a35bb41dbdbe3afb6520745eb9bd34dfa7a27dbf'
- '1d5bb9a9cf809f26508e4611fb564e050b554036a679ec28b79827785a3f46c8')
+pkgrel=5
+pkgdesc="A library of code shared between tuxmath and tuxtype."
+arch=("i686" "x86_64")
+url="https://github.com/tux4kids/${pkgname}"
+license=("GPL")
+depends=("librsvg" "sdl_image" "sdl_mixer" "sdl_net" "sdl_pango")
+options=(!docs)
+source=(
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/tux4kids/${pkgname}/archive/upstream/${pkgver}.tar.gz"
+ "libpng15.patch"
+ "https://sources.debian.org/data/main/t/t4kcommon/0.1.1-6/debian/patches/916060_bugfix.patch"
+ "wrapped_lines.patch"
+)
+sha256sums=(
+ "be4cadbcf2728ed6efb1c71e96c209184a7829b65af3625d9410a29fb2fd775a"
+ "e2998909bed025becbe52969eb53b40eede05e75285b400cbafac6207cf82c3f"
+ "1d5bb9a9cf809f26508e4611fb564e050b554036a679ec28b79827785a3f46c8"
+ "0643e9eada6fdba1a295798ea3d09be71cafbf5af6ba132dd15a4f372d58dcf3"
+)
prepare() {
- cd "$srcdir/$pkgname-upstream-$pkgver"
- patch -Np2 -i "${srcdir}/libpng15.patch"
+ cd "${srcdir}/${pkgname}-upstream-${pkgver}"
+
+ patch -Np1 -i "${srcdir}/libpng15.patch"
patch -Np1 -i "${srcdir}/916060_bugfix.patch"
+ patch -Np1 -i "${srcdir}/wrapped_lines.patch"
}
build() {
- cd "$srcdir/$pkgname-upstream-$pkgver"
- ./configure --prefix=/usr
+ cd "${srcdir}/${pkgname}-upstream-${pkgver}"
+
+ ./configure \
+ --prefix=/usr
make
}
package() {
- cd "$srcdir/$pkgname-upstream-$pkgver"
+ cd "${srcdir}/${pkgname}-upstream-${pkgver}"
- make DESTDIR=$pkgdir install
+ make DESTDIR="${pkgdir}" install
}
diff --git a/libpng15.patch b/libpng15.patch
index 29991544ddbf..59936d6c60b7 100644
--- a/libpng15.patch
+++ b/libpng15.patch
@@ -1,6 +1,8 @@
---- src/t4k_common-0.1.1/src/t4k_loaders.c 2011-04-08 05:46:07.000000000 +0300
-+++ src.new/t4k_common-0.1.1/src/t4k_loaders.c 2012-05-02 10:35:41.836670434 +0300
-@@ -1028,12 +1028,9 @@
+diff --git a/src/t4k_loaders.c b/src/t4k_loaders.c
+index 7248e35..61fe63f 100644
+--- a/src/t4k_loaders.c
++++ b/src/t4k_loaders.c
+@@ -1028,12 +1028,9 @@ static int do_png_save(FILE * fi, const char *const fname, SDL_Surface * surf)
{
png_init_io(png_ptr, fi);
diff --git a/wrapped_lines.patch b/wrapped_lines.patch
new file mode 100644
index 000000000000..be3937f755bb
--- /dev/null
+++ b/wrapped_lines.patch
@@ -0,0 +1,13 @@
+diff --git a/src/t4k_common.h b/src/t4k_common.h
+index d4676e7..27e635c 100644
+--- a/src/t4k_common.h
++++ b/src/t4k_common.h
+@@ -239,7 +239,7 @@ MFStrategy;
+ #define MAX_LINES 128 //!< Maximum lines to wrap.
+ #define MAX_LINEWIDTH 256 //!< Maximum characters of each line.
+
+-char wrapped_lines[MAX_LINES][MAX_LINEWIDTH]; //!< Global buffer for wrapped lines.
++extern char wrapped_lines[MAX_LINES][MAX_LINEWIDTH]; //!< Global buffer for wrapped lines.
+
+ //TODO separate headers for different areas a la SDL?
+