summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Taboada2019-07-27 20:34:58 -0700
committerMichael Taboada2019-07-27 20:34:58 -0700
commit3e5a7a784b56bac2a10e21452016ed3515a6f60e (patch)
tree13e416d3220f27bad21535226e4de486725bab1e
downloadaur-3e5a7a784b56bac2a10e21452016ed3515a6f60e.tar.gz
Fixed t4kcommon
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD46
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9974a7492ee8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = t4kcommon-git
+ pkgdesc = Common library for code shared by TuxType and TuxMath
+ pkgver = r4.013d039
+ pkgrel = 1
+ url = http://tux4kids.alioth.debian.org/
+ arch = armv7h
+ arch = aarch64
+ arch = aarch64
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = gettext
+ makedepends = libtool
+ makedepends = make
+ depends = sdl_image
+ depends = sdl_mixer
+ depends = sdl_pango
+ depends = sdl_net
+ depends = libpng
+ depends = librsvg
+ depends = libxml2
+ options = !docs
+ source = git+https://gitlab.com/stormdragon2976/t4k-common-arch
+ sha256sums = SKIP
+
+pkgname = t4kcommon-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0081ed12bd9c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Michael Taboada <michael@2mb.solutions>
+# Maintainer: Storm Dragon <stormdragon2976@gmail.com>
+# Contributor: Alexandre Moine < nobrakal at cthugha dot org >
+# Contributor: Tasos Latsas < tlatsas2000 at gmail dot com >
+# Contributor: Kyle < kyle at free 2 dot ml >
+
+pkgname=t4kcommon-git
+_gitname=t4k-common-arch
+pkgver=r4.013d039
+
+
+pkgrel=1
+pkgdesc="Common library for code shared by TuxType and TuxMath"
+arch=('armv7h' 'aarch64' 'aarch64' 'i686' 'x86_64')
+url="http://tux4kids.alioth.debian.org/"
+license=('GPL')
+depends=('sdl_image' 'sdl_mixer' 'sdl_pango' 'sdl_net' 'libpng' 'librsvg' 'libxml2')
+makedepends=('autoconf' 'automake' 'gettext' 'libtool' 'make')
+options=('!docs')
+replace=('t4k_common')
+source=("git+https://gitlab.com/stormdragon2976/t4k-common-arch")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ # Use the tag of the last commit
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+#prepare() {
+# cd "$srcdir/$_gitname"
+# patch -Np2 -i "$srcdir/libpng15.patch"
+#}
+
+build() {
+ cd "$srcdir/$_gitname"
+ autoreconf -if .
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+
+ make DESTDIR=$pkgdir install
+}