summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosef Vybíhal2018-12-10 15:24:26 +0100
committerJosef Vybíhal2018-12-10 15:24:26 +0100
commit13a7bfbfb5aa32011e373da4fb9c826374ee6a57 (patch)
tree5876514afa697f3f695622a269386caa652bad8e
downloadaur-13a7bfbfb5aa32011e373da4fb9c826374ee6a57.tar.gz
Continuation of package tracktion-7-free-daw
Apparently renaming packages is not supported: https://lists.archlinux.org/pipermail/aur-general/2011-July/015194.html https://lists.archlinux.org/pipermail/aur-general/2011-June/014866.html So I was not able to push repo with different name: Enumerating objects: 33, done. Counting objects: 100% (33/33), done. Delta compression using up to 8 threads Compressing objects: 100% (29/29), done. Writing objects: 100% (33/33), 4.73 KiB | 1.58 MiB/s, done. Total 33 (delta 11), reused 0 (delta 0) remote: error: The following error occurred when parsing commit remote: error: 3e6b6719a14fef7658744077138342c2db713c52: remote: error: missing install file: tracktion-7-free-daw.install remote: error: hook declined to update refs/heads/master To ssh://aur.archlinux.org/t7-daw.git ! [remote rejected] master -> master (hook declined) error: failed to push some refs to 'ssh://aur@aur.archlinux.org/t7-daw.git' So I created new repo. Changes I made: - .install: let pacman hooks handle desktop files and icons - left only printing note - package rename
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD40
-rw-r--r--t7-daw.install14
4 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9181f9b5e97e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = t7-daw
+ pkgdesc = The world's best, fully featured, completely unlimited free daw for all music creators.
+ pkgver = 7.2.1
+ pkgrel = 4
+ url = https://www.tracktion.com/products/t7-daw
+ install = t7-daw.install
+ arch = x86_64
+ depends = alsa-lib
+ depends = libgl
+ depends = desktop-file-utils
+ depends = shared-mime-info
+ depends = curl
+ depends = libx11
+ depends = libxext
+ depends = libxinerama
+ depends = freetype2
+ depends = libcurl-gnutls
+ optdepends = jack: A low-latency audio server
+ optdepends = ladspa-plugins: A set of ladspa plugins
+ provides = t7-daw=7.2.1
+ replaces = tracktion-7-free-daw
+ options = !emptydirs
+ options = !strip
+ source = TracktionInstall_7_Linux_64Bit_latest.deb::https://cdn.tracktion.com/file/tracktiondownload/t7/TracktionInstall_7_Linux_64Bit_latest.deb
+ sha256sums = 904b120c2d597a2f504854a3a61883ca2b1f1066fb921aca423fdb42976d8db0
+
+pkgname = t7-daw
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..83bb4a4599c5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.deb
+pkg/
+src/
+/.project
+t7-daw*.pkg* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec534d9008be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Josef Vybíhal (josef.vybihal@gmail.com)
+# Dependencies come from PKGBUILD by ftonello
+# This package installs into /opt and symlinks to /usr
+
+pkgname=t7-daw
+pkgver=7.2.1
+pkgrel=4
+pkgdesc="The world's best, fully featured, completely unlimited free daw for all music creators."
+arch=('x86_64')
+url="https://www.tracktion.com/products/t7-daw"
+#license=('custom:xx')
+depends=(
+ 'alsa-lib' 'libgl' 'desktop-file-utils' 'shared-mime-info' 'curl' 'libx11'
+ 'libxext' 'libxinerama' 'freetype2' 'libcurl-gnutls')
+optdepends=(
+ 'jack: A low-latency audio server'
+ 'ladspa-plugins: A set of ladspa plugins'
+)
+provides=("t7-daw=${pkgver}")
+options=('!emptydirs' '!strip')
+install=${pkgname}.install
+replaces=("tracktion-7-free-daw")
+source=("TracktionInstall_7_Linux_64Bit_latest.deb::https://cdn.tracktion.com/file/tracktiondownload/t7/TracktionInstall_7_Linux_64Bit_latest.deb")
+sha256sums=('904b120c2d597a2f504854a3a61883ca2b1f1066fb921aca423fdb42976d8db0')
+
+package() {
+ msg2 "Extracting the data.tar.lzma"
+ mkdir -p ${pkgdir}/opt/${pkgname}
+ tar -x --lzma -f data.tar.lzma -C "${pkgdir}/opt/${pkgname}/"
+
+ cd "$pkgdir"
+ install -dm0755 opt/$pkgname usr/bin usr/share/applications/ usr/share/doc usr/share/mime/packages usr/share/pixmaps
+
+ ln -sf /opt/$pkgname/usr/bin/Tracktion7 usr/bin/Tracktion7
+ ln -sf /opt/$pkgname/usr/bin/Tracktion7 usr/bin/tracktion7
+ ln -sf /opt/$pkgname/usr/share/applications/tracktion7.desktop usr/share/applications/tracktion7.desktop
+ ln -sf /opt/$pkgname/usr/share/doc/tracktion7 usr/share/doc/tracktion7
+ ln -sf /opt/$pkgname/usr/share/mime/packages/tracktion7.xml usr/share/mime/packages/tracktion7.xml
+ ln -sf /opt/$pkgname/usr/share/pixmaps/tracktion7.png usr/share/pixmaps/tracktion7.png
+}
diff --git a/t7-daw.install b/t7-daw.install
new file mode 100644
index 000000000000..a7fb34e7d25e
--- /dev/null
+++ b/t7-daw.install
@@ -0,0 +1,14 @@
+# Some colored makepkg-like functions
+note() {
+ printf "${BLUE}==>${ALL_OFF}${YELLOW} NOTE:${ALL_OFF}${BOLD} ${1}${ALL_OFF}\n"
+}
+
+ALL_OFF="$(tput sgr0)"
+BOLD="$(tput bold)"
+BLUE="${BOLD}$(tput setaf 4)"
+YELLOW="${BOLD}$(tput setaf 3)"
+
+
+post_install() {
+ note "Do not forget to register at https://marketplace.tracktion.com/shop/free-daw to create your login and use the DAW for free."
+} \ No newline at end of file