summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Bernardoff2018-01-28 01:17:20 +0100
committerVincent Bernardoff2018-01-28 01:17:20 +0100
commitea3527df0d30207e9684f284ad454a7382e050be (patch)
tree65504165d63dd2a064c753803444a271a4b20548
downloadaur-ea3527df0d30207e9684f284ad454a7382e050be.tar.gz
Initial commit.
-rw-r--r--.SRCINFO23
-rw-r--r--LICENSE31
-rw-r--r--PKGBUILD34
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..479a5fae291f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ta-lib-git
+ pkgdesc = A library providing common functions for the technical analysis of financial market data
+ pkgver = v0.6.0.rc.1.r3.ga61875c1
+ pkgrel = 1
+ url = https://github.com/vbmithr/ta-lib
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = BSD
+ makedepends = git
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = m4
+ makedepends = make
+ source = ta-lib::git+https://github.com/vbmithr/ta-lib
+ source = LICENSE
+ sha256sums = SKIP
+ sha256sums = 10ddcfc0d685173fdee2d7e8791540bb1a8526a0f66f7795bdf7dad23457b10e
+
+pkgname = ta-lib-git
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..10a6e28fbbd1
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,31 @@
+TA-Lib Copyright (c) 1999-2008, Mario Fortier
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or
+without modification, are permitted provided that the following
+conditions are met:
+
+- Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+
+- Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in
+ the documentation and/or other materials provided with the
+ distribution.
+
+- Neither name of author nor the names of its contributors
+ may be used to endorse or promote products derived from this
+ software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
+FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
+REGENTS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
+INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE
+OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
+EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8dbd6be4c96f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Vincent Bernardoff <va AT luminar.eu.org>
+
+pkgname=ta-lib-git
+pkgver=v0.6.0.rc.1.r3.ga61875c1
+pkgrel=1
+pkgdesc='A library providing common functions for the technical analysis of financial market data'
+url='https://github.com/vbmithr/ta-lib'
+license=('BSD')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
+makedepends=('git' 'autoconf' 'automake' 'm4' 'make')
+source=(${pkgname%-git}::git+https://github.com/vbmithr/ta-lib
+ 'LICENSE')
+sha256sums=('SKIP'
+ '10ddcfc0d685173fdee2d7e8791540bb1a8526a0f66f7795bdf7dad23457b10e')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname%-git}"
+
+ autoreconf -i
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${pkgname%-git}"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}