summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2024-03-18 16:22:17 -0400
committerChris Severance2024-03-18 16:22:17 -0400
commit35bfb40c1ea316fee9a0120ee5f681c92a98aa53 (patch)
treee5b131e6fe17e3b029903888e47fdc7419981c17
parent78cfded164a85c66b2930cda2c34fdd08272a60a (diff)
downloadaur-tab-git.tar.gz
autu: Update to 9.2.r3.gecb7eca-1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD19
2 files changed, 18 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 023a4fcf1bf8..22c3a1eeb60d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
+# Generated by mksrcinfo v8
+# Mon Mar 18 20:22:17 UTC 2024
pkgbase = tab-git
pkgdesc = A modern text processing language similar to awk in spirit. (But not similar in design philosophy, implementation or syntax.)
- pkgver = 20150731.r138.1c27b59
+ pkgver = 9.2.r3.gecb7eca
pkgrel = 1
- url = https://bitbucket.org/tkatchev/tab
+ url = https://github.com/ivan-tkatchev/tab
arch = x86_64
arch = i686
- license = BSL
+ license = BSL-1.0
makedepends = git
makedepends = gcc
provides = tab
conflicts = tab
- source = TAB-GIT::git+https://bitbucket.org/tkatchev/tab.git
+ source = tab-git::git+https://github.com/ivan-tkatchev/tab.git
+ md5sums = SKIP
sha256sums = SKIP
pkgname = tab-git
diff --git a/PKGBUILD b/PKGBUILD
index 1451a4c8696a..9a19281e2fac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,31 +3,34 @@
set -u
_pkgname='tab'
pkgname="${_pkgname}-git"
-pkgver=20150731.r138.1c27b59
+pkgver=9.2.r3.gecb7eca
pkgrel=1
pkgdesc="A modern text processing language similar to awk in spirit. (But not similar in design philosophy, implementation or syntax.)"
arch=('x86_64' 'i686')
-url='https://bitbucket.org/tkatchev/tab'
-license=('BSL')
+#url='https://bitbucket.org/tkatchev/tab'
+url='https://github.com/ivan-tkatchev/tab'
+license=('BSL-1.0')
makedepends=('git' 'gcc')
provides=("${_pkgname}") # =${pkgver%%.r*} # Not useful until we get a version better than a date.
conflicts=("${_pkgname}")
-_srcdir="${pkgname^^}"
-source=("${_srcdir}::git+https://bitbucket.org/tkatchev/tab.git")
+_srcdir="${pkgname}"
+source=("${_srcdir}::git+${url}.git")
+md5sums=('SKIP')
sha256sums=('SKIP')
pkgver() {
set -u
cd "${_srcdir}"
- printf "%s.r%s.%s" "$(git show -s --format=%ci HEAD | cut -d' ' -f1 | sed -e 's:-::g')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- #git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ # git log -n1 --format='%ci'
+ #printf "%s.r%s.%s" "$(git log -n1 --format='%ci' | cut -d' ' -f1 | sed -e 's:-::g')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed -E -e 's/([^-]*-g)/r\1/' -e 's/-/./g'
set +u
}
build() {
set -u
cd "${_srcdir}"
- make -s -j "$(nproc)"
+ nice make -s
set +u
}