summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2020-05-01 19:42:56 +0000
committerAntonio Rojas2020-05-01 19:42:56 +0000
commit81d79e4aa36fe646d85780c814a7d6f9dc3f374e (patch)
treea69304a1312cd2486e8812197e5372fd371fd387
downloadaur-81d79e4aa36fe646d85780c814a7d6f9dc3f374e.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
-rw-r--r--config.h58
-rw-r--r--tabbed.install28
4 files changed, 137 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0214a1eae77
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = tabbed
+ pkgdesc = Simple generic tabbed fronted to xembed aware applications.
+ pkgver = 0.6
+ pkgrel = 3
+ url = https://tools.suckless.org/tabbed
+ install = tabbed.install
+ arch = x86_64
+ license = custom:MIT/X
+ depends = libx11
+ source = https://dl.suckless.org/tools/tabbed-0.6.tar.gz
+ source = config.h
+ md5sums = 7898992feb9358e0196119750b77b42c
+ md5sums = 910b1cbcf62051064c58029987e05db8
+
+pkgname = tabbed
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..751a7037ad42
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
+# Contributor: totoloco <totoloco at gmx>
+
+pkgname=tabbed
+pkgver=0.6
+pkgrel=3
+pkgdesc='Simple generic tabbed fronted to xembed aware applications.'
+arch=('x86_64')
+url='https://tools.suckless.org/tabbed'
+license=('custom:MIT/X')
+depends=('libx11')
+install='tabbed.install'
+source=("https://dl.suckless.org/tools/${pkgname}-${pkgver}.tar.gz"
+ 'config.h')
+md5sums=('7898992feb9358e0196119750b77b42c'
+ '910b1cbcf62051064c58029987e05db8')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ cp "${srcdir}/config.h" config.h
+
+ sed -i 's/CPPFLAGS =/CPPFLAGS +=/g' config.mk
+ sed -i 's/CFLAGS =/CFLAGS +=/g' config.mk
+ sed -i 's/LDFLAGS =/LDFLAGS +=/g' config.mk
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+ install -Dm0644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/config.h b/config.h
new file mode 100644
index 000000000000..ceda9f704531
--- /dev/null
+++ b/config.h
@@ -0,0 +1,58 @@
+/* See LICENSE file for copyright and license details. */
+
+/* appearance */
+static const char font[] = "-*-*-medium-*-*-*-14-*-*-*-*-*-*-*";
+static const char* normbgcolor = "#222222";
+static const char* normfgcolor = "#cccccc";
+static const char* selbgcolor = "#555555";
+static const char* selfgcolor = "#ffffff";
+static const char before[] = "<";
+static const char after[] = ">";
+static const int tabwidth = 200;
+static const Bool foreground = True;
+
+/*
+ * Where to place a new tab when it is opened. When npisrelative is True,
+ * then the current position is changed + newposition. If npisrelative
+ * is False, then newposition is an absolute position.
+ */
+static int newposition = 0;
+static Bool npisrelative = False;
+
+#define SETPROP(p) { \
+ .v = (char *[]){ "/bin/sh", "-c", \
+ "prop=\"`xwininfo -children -id $1 | grep '^ 0x' | sed -e's@^ *\\(0x[0-9a-f]*\\) \"\\([^\"]*\\)\".*@\\1 \\2@' | xargs -0 printf %b | dmenu -l 10`\" &&" \
+ "xprop -id $1 -f $0 8s -set $0 \"$prop\"", \
+ p, winid, NULL \
+ } \
+}
+
+#define MODKEY ControlMask
+static Key keys[] = { \
+ /* modifier key function argument */
+ { MODKEY|ShiftMask, XK_Return, focusonce, { 0 } },
+ { MODKEY|ShiftMask, XK_Return, spawn, { 0 } },
+ { MODKEY, XK_t, spawn, SETPROP("_TABBED_SELECT_TAB") },
+
+ { MODKEY|ShiftMask, XK_l, rotate, { .i = +1 } },
+ { MODKEY|ShiftMask, XK_h, rotate, { .i = -1 } },
+ { MODKEY|ShiftMask, XK_j, movetab, { .i = -1 } },
+ { MODKEY|ShiftMask, XK_k, movetab, { .i = +1 } },
+ { MODKEY, XK_Tab, rotate, { .i = 0 } },
+
+ { MODKEY, XK_1, move, { .i = 0 } },
+ { MODKEY, XK_2, move, { .i = 1 } },
+ { MODKEY, XK_3, move, { .i = 2 } },
+ { MODKEY, XK_4, move, { .i = 3 } },
+ { MODKEY, XK_5, move, { .i = 4 } },
+ { MODKEY, XK_6, move, { .i = 5 } },
+ { MODKEY, XK_7, move, { .i = 6 } },
+ { MODKEY, XK_8, move, { .i = 7 } },
+ { MODKEY, XK_9, move, { .i = 8 } },
+ { MODKEY, XK_0, move, { .i = 9 } },
+
+ { MODKEY, XK_q, killclient, { 0 } },
+
+ { 0, XK_F11, fullscreen, { 0 } },
+};
+
diff --git a/tabbed.install b/tabbed.install
new file mode 100644
index 000000000000..c44096d56fd5
--- /dev/null
+++ b/tabbed.install
@@ -0,0 +1,28 @@
+pre_install() {
+ echo "-- Edit config.h in PKGBUILD's directory (generally /var/abs/community/tabbed/)"
+ echo "-- and rebuild package if you want to change settings."
+ /bin/true
+}
+
+post_install() {
+ /bin/true
+}
+
+pre_upgrade() {
+ echo "-- Edit config.h in PKGBUILD's directory (generally /var/abs/community/tabbed/)"
+ echo "-- and rebuild package if you want to change settings."
+ /bin/true
+}
+
+post_upgrade() {
+ /bin/true
+}
+
+pre_remove() {
+ /bin/true
+}
+
+post_remove() {
+ /bin/true
+}
+