summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesse McClure2023-02-18 19:48:23 -0600
committerJesse McClure2023-02-18 19:48:23 -0600
commit204823edfde2bb6175aca0eed217c5b14b094304 (patch)
tree64886c6f8ec4f9c4d7c454a84e9c84fba8dce827
parent3e322470608e0a32b20fa7844d5746c7d4233b04 (diff)
downloadaur-204823edfde2bb6175aca0eed217c5b14b094304.tar.gz
update to 3.0 line for wlroots 0.16
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad807e96b246..93a6de133d21 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
pkgbase = tabby-fossil
pkgdesc = Tabbed tiling wayland compositor
- pkgver = 2.0
+ pkgver = 3.0.1.ff51b00113
pkgrel = 1
url = https://code.jessemcclure.org/tabby
arch = x86_64
license = MIT
makedepends = fossil
makedepends = wayland-protocols
- depends = cairo
- depends = glib2
depends = glibc
+ depends = libinput
depends = libxkbcommon
- depends = nkk
- depends = pango
+ depends = nkk-fossil
depends = wayland
- depends = wlroots0.15
+ depends = wlroots
optdepends = polkit: starting wlroots-based compositors without seatd
source = fossil+https://code.jessemcclure.org/tabby
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 6b0588126656..3bb745d66f76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Jesse McClure <code at jessemcclure dot org>
_fossil=tabby
pkgname=${_fossil}-fossil
-pkgver=2.0
+pkgver=3.0.1.ff51b00113
pkgrel=1
pkgdesc='Tabbed tiling wayland compositor'
arch=('x86_64')
license=('MIT')
-depends=(cairo glib2 glibc libxkbcommon nkk pango wayland wlroots0.15)
+depends=(glibc libinput libxkbcommon nkk-fossil wayland wlroots)
makedepends=(fossil wayland-protocols)
optdepends=('polkit: starting wlroots-based compositors without seatd')
url=https://code.jessemcclure.org/${_fossil}
@@ -15,10 +15,7 @@ sha256sums=(SKIP)
pkgver() {
cd "${srcdir}/${_fossil}"
- printf '%sr%s.%s\n' \
- $(fossil tag list | grep '[0-9\.*]' | sort -r | sed 1q) \
- $(fossil info | sed -n '$s/[a-z:-]* *//p') \
- $(fossil timeline -n 1 -t ci -F %h | sed 1q)
+ fossil describe | tr - .
}
build() {