summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesse McClure2021-09-05 13:50:08 -0500
committerJesse McClure2021-09-05 13:50:08 -0500
commit9468965fdf314941f1816935466c9fb0f617086f (patch)
treedf292da438076dc93cc8a2becd6453445bb3c9db
downloadaur-9468965fdf314941f1816935466c9fb0f617086f.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9de9c8a0fa6e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = tabby-fossil
+ pkgdesc = Tabbed tiling wayland compositor
+ pkgver = 1.2r54.ff6db57fc2
+ pkgrel = 1
+ url = https://code.jessemcclure.org/tabby
+ arch = x86_64
+ license = MIT
+ makedepends = fossil
+ depends = cairo
+ depends = fontconfig
+ depends = glibc
+ depends = libxkbcommon
+ depends = wayland
+ depends = wlroots
+ source = fossil+https://code.jessemcclure.org/tabby
+ sha256sums = SKIP
+
+pkgname = tabby-fossil
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..758279f6fa1b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jesse McClure <code at jessemcclure dot org>
+_fossil=tabby
+pkgname=${_fossil}-fossil
+pkgver=1.2r54.ff6db57fc2
+pkgrel=1
+pkgdesc='Tabbed tiling wayland compositor'
+arch=('x86_64')
+license=('MIT')
+depends=(cairo fontconfig glibc libxkbcommon wayland wlroots)
+makedepends=(fossil)
+url=https://code.jessemcclure.org/${_fossil}
+source=(fossil+${url})
+sha256sums=(SKIP)
+
+pkgver() {
+ cd "${srcdir}/${_fossil}"
+ printf '%sr%s.%s\n' \
+ $(fossil tag list | grep '[0-9\.*]' | sort -r | sed 1q) \
+ $(fossil info | sed -n '$s/[a-z:-]* *//p') \
+ $(fossil timeline -n 1 -t ci -F %h | sed 1q)
+}
+
+build() {
+ cd "${srcdir}/${_fossil}"
+ make protocols
+ make PREFIX=/usr
+}
+
+package() {
+ cd "${srcdir}/${_fossil}"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+