summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWinston Astrachan2020-07-26 18:48:14 -0400
committerWinston Astrachan2020-07-26 18:49:00 -0400
commitb9c55694899c1b650ce13d933dd5d72aabb70847 (patch)
tree378879c32bbb7fdb3846e6852d0e8483b1bd98e7
parentcbd1d8a0c2025d3131ef706521ac9ec8dbe4139b (diff)
downloadaur-b9c55694899c1b650ce13d933dd5d72aabb70847.tar.gz
refactor: modify desktop file without patch
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD29
-rw-r--r--tableplus.desktop.patch11
3 files changed, 13 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95ebb4fe4fe5..afbc5675ae42 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,10 +9,8 @@ pkgbase = tableplus
depends = libgee
depends = gnome-keyring
source = LICENSE
- source = tableplus.desktop.patch
source = https://deb.tableplus.com/debian/pool/main/t/tableplus/tableplus_0.1.62_amd64.deb
sha256sums = 76f924b1ebad5309ccf0dd7f3fe3d1b57ff3088b208a603900b0e240fdb5debb
- sha256sums = ffe6b081bf6e868c3b9b9c3b9088af37a74cb7a517c5de927c0ad216ee66eed1
sha256sums = 28cdc3921d3ecc46aafafa88e0f088427623b4058332bce2bc877b70cf5d6c05
pkgname = tableplus
diff --git a/PKGBUILD b/PKGBUILD
index ea1bf0c413f5..59afc39affb2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,38 +4,35 @@
pkgname=tableplus
pkgver=0.1.62
pkgrel=1
-pkgdesc="Modern, native, and friendly GUI tool for relational databases (Alpha)"
+pkgdesc='Modern, native, and friendly GUI tool for relational databases (Alpha)'
arch=('x86_64')
-url="https://tableplus.com/"
+url='https://tableplus.com/'
license=('custom')
depends=('gtksourceview3' 'libgee' 'gnome-keyring')
source=('LICENSE'
- 'tableplus.desktop.patch'
"https://deb.tableplus.com/debian/pool/main/t/tableplus/tableplus_${pkgver}_amd64.deb"
)
sha256sums=('76f924b1ebad5309ccf0dd7f3fe3d1b57ff3088b208a603900b0e240fdb5debb'
- 'ffe6b081bf6e868c3b9b9c3b9088af37a74cb7a517c5de927c0ad216ee66eed1'
'28cdc3921d3ecc46aafafa88e0f088427623b4058332bce2bc877b70cf5d6c05'
)
prepare() {
- cd "$srcdir"
- tar -xf data.tar.xz
- patch --forward --strip=1 --input="${srcdir}/tableplus.desktop.patch"
+ tar -xf "${srcdir}/data.tar.xz"
}
package() {
cd "$srcdir"
- install -d "$pkgdir/usr/local/bin/"
- install -d "$pkgdir/usr/share/applications/"
- install -d "$pkgdir/opt/tableplus/"
+ install -d "${pkgdir}/opt/tableplus/"
+ install -Dm755 opt/tableplus/tableplus -t "$pkgdir/usr/local/bin/"
+ install -Dm644 opt/tableplus/tableplus.desktop -t "${pkgdir}/usr/share/applications/"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cp -r opt/tableplus/resource "${pkgdir}/opt/tableplus/"
- install -Dm755 opt/tableplus/tableplus "$pkgdir/usr/local/bin/"
- install -Dm644 opt/tableplus/tableplus.desktop "$pkgdir/usr/share/applications/"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ echo "" >> "${pkgdir}/usr/share/applications/tableplus.desktop"
+ echo "Categories=Utility;Development;" >> "${pkgdir}/usr/share/applications/tableplus.desktop"
+ echo "Comment=Modern, native, and friendly GUI tool for relational databases (Alpha)" >> "${pkgdir}/usr/share/applications/tableplus.desktop"
- cp -r opt/tableplus/resource "$pkgdir/opt/tableplus/"
- find opt/tableplus/ -type d -exec chmod 755 {} \;
- find opt/tableplus/ -type f -exec chmod 644 {} \;
+ find "${pkgdir}/opt/tableplus/" -type d -exec chmod 755 {} \;
+ find "${pkgdir}/opt/tableplus/" -type f -exec chmod 644 {} \;
}
diff --git a/tableplus.desktop.patch b/tableplus.desktop.patch
deleted file mode 100644
index 20eabcb468fe..000000000000
--- a/tableplus.desktop.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- /opt/tableplus/tableplus.desktop 2020-03-02 09:19:32.000000000 -0500
-+++ /opt/tableplus/tableplus.desktop 2020-03-02 16:07:55.688490096 -0500
-@@ -3,4 +3,6 @@
- Type=Application
- Exec=/usr/local/bin/tableplus
- Icon=/opt/tableplus/resource/image/logo.png
--Terminal=false
-\ No newline at end of file
-+Terminal=false
-+Categories=Utility;Development;
-+Comment=Modern, native, and friendly GUI tool for relational databases (Alpha)