summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbegin-theadventure2024-02-12 03:22:30 +0100
committerbegin-theadventure2024-02-12 03:22:30 +0100
commit63357d56bb33167e637415d0d126389e25f730dc (patch)
treea286862b2167cbd0b51011352b3a60bc4f27005c
parent66f18bfc5507888bc90c5df8c2a8cbf80472d6b5 (diff)
downloadaur-63357d56bb33167e637415d0d126389e25f730dc.tar.gz
Clean up, depends, license
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4355c186722e..00d8f31f07b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,18 @@
pkgbase = tacentview-bin
pkgdesc = An image and texture viewer for tga, png, apng, exr, dds, ktx, ktx2, astc, pkm, qoi, gif, hdr, jpg, tif, ico, webp, and bmp files. Uses Dear ImGui, OpenGL and Tacent (binary release)
pkgver = 1.0.43
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/bluescan/tacentview
arch = x86_64
license = ISC
+ depends = libx11
+ depends = hicolor-icon-theme
+ depends = libxcb
provides = tacentview
conflicts = tacentview
source = https://github.com/bluescan/tacentview/releases/download/v1.0.43/tacentview_1.0-43.deb
+ source = https://github.com/bluescan/tacentview/raw/master/LICENSE
sha256sums = 0974df7bae147a732c5bf8b1c0d9bbefe259bbac6d9b76ad5c72956ea090fc87
+ sha256sums = SKIP
pkgname = tacentview-bin
diff --git a/PKGBUILD b/PKGBUILD
index 547e651e0abf..4d9a6a617078 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,26 @@
pkgname=tacentview-bin
pkgver=1.0.43
_pkgver=1.0-43
-pkgrel=1
+pkgrel=2
pkgdesc="An image and texture viewer for tga, png, apng, exr, dds, ktx, ktx2, astc, pkm, qoi, gif, hdr, jpg, tif, ico, webp, and bmp files. Uses Dear ImGui, OpenGL and Tacent (binary release)"
url="https://github.com/bluescan/tacentview"
-arch=('x86_64')
license=('ISC')
+arch=('x86_64')
+depends=('libx11' 'hicolor-icon-theme' 'libxcb')
provides=("tacentview")
conflicts=("tacentview")
-source=("$url/releases/download/v$pkgver/tacentview_$_pkgver.deb")
-sha256sums=('0974df7bae147a732c5bf8b1c0d9bbefe259bbac6d9b76ad5c72956ea090fc87')
+source=("$url/releases/download/v$pkgver/tacentview_$_pkgver.deb"
+ "$url/raw/master/LICENSE")
+sha256sums=('0974df7bae147a732c5bf8b1c0d9bbefe259bbac6d9b76ad5c72956ea090fc87'
+ 'SKIP')
prepare() {
-# Extract
tar --use-compress-program=unzstd -xf data.tar.zst
+ cd usr
+ rm bin/.gitignore share/tacentview/Data/.gitignore
}
package() {
-# Install
mv usr "$pkgdir"
-# Delete an unnecessary file
- rm "$pkgdir/usr/bin/.gitignore"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}