diff options
author | Canas Simon | 2023-06-07 21:15:15 +0200 |
---|---|---|
committer | Canas Simon | 2023-06-07 21:15:15 +0200 |
commit | dd9a1e933377bc81f201ededd4f13bf14b7e5b38 (patch) | |
tree | ac3d52e2bdd4953744f1fd27291a1e79bb84bc11 | |
parent | 3d7bae6ac3b6d9b69e803e69121678f63d3fc248 (diff) | |
download | aur-dd9a1e933377bc81f201ededd4f13bf14b7e5b38.tar.gz |
Recent GCC builds not working anymore, temporary workaround to GCC12
-rw-r--r-- | PKGBUILD | 6 |
1 files changed, 3 insertions, 3 deletions
@@ -2,14 +2,14 @@ # Contributor: frousties _pkgname=tacentview pkgname=${_pkgname}-git -pkgver=1.0.35.r31.g303f9b0 +pkgver=1.0.39.r0.g3f6b1cb pkgrel=1 pkgdesc="Tacent View. An image and texture viewer for tga, png, apng, exr, dds, gif, hdr, jpg, tiff, ico, webp, and bmp files." arch=('i686' 'x86_64') url="https://github.com/bluescan/${_pkgname}" license=('ISC') groups=('') -depends=('gcc' 'libx11' 'cmake' 'ninja' 'dpkg') +depends=('gcc12' 'libx11' 'cmake' 'ninja' 'dpkg') options=('!strip' '!emptydirs') source_x86_64=("git+https://github.com/bluescan/${_pkgname}.git") sha512sums_x86_64=('SKIP') @@ -20,7 +20,7 @@ pkgver() { } build() { - cmake -S "${_pkgname}" -B build -GNinja -DPACKAGE_DEB=True + cmake -S "${_pkgname}" -B build -GNinja -DPACKAGE_DEB=True -DCMAKE_CXX_COMPILER=gcc-12 -DCMAKE_C_COMPILER=gcc-12 ninja -C build install } |