summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjmcb2022-09-11 13:25:37 +0100
committerjmcb2022-09-11 13:25:37 +0100
commitaa6e33cd8100d5b8232774e6679b2338b0ca0f8b (patch)
tree8dc5c366047ef5f69ab9f67cd39362ff95ec6a83
parent2092a8f6967343fb593b7306a57b074c733371d6 (diff)
downloadaur-aa6e33cd8100d5b8232774e6679b2338b0ca0f8b.tar.gz
Create run scripts
-rw-r--r--PKGBUILD21
-rwxr-xr-xtachyons-client3
-rwxr-xr-xtachyons-server3
3 files changed, 20 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1854ad7c1af3..109cee5dca07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,16 +6,21 @@ pkgdesc="It's like FTL but multiplayer :)"
arch=('any')
url="https://spektor.itch.io/tachyon"
license=('custom')
-depends=('java-runtime<15' 'jre11-openjdk')
+depends=('java-runtime<15' 'jre8-openjdk'
+ 'alsa-lib' 'openal')
makedepends=()
checkdepends=()
optdepends=()
provides=()
conflicts=()
replaces=()
-source=("file://Tachyons a0834 lin.zip")
+source=("file://Tachyons a0834 lin.zip"
+ "${pkgname}-client"
+ "${pkgname}-server")
noextract=()
-sha256sums=('7d2f77204595c5c1cf7931cbcc1207e675213dc0f0693ea9f6192e58509027cd')
+sha256sums=('7d2f77204595c5c1cf7931cbcc1207e675213dc0f0693ea9f6192e58509027cd'
+ '1f33ccd0e0b55d9ddda075d300bd7d003df704335aed0b7429c1dc7ea94c25a4'
+ 'eadb62ef496b569acdc49f25aa6abe2f2a9f5504b173edd04de4a5a2db4535ba')
_name="Tachyons a0834"
@@ -29,9 +34,11 @@ prepare() {
}
package() {
- cd "${_name}"
-
_dest="${pkgdir}"/opt/${pkgname}
- install -dm644 ${_dest}
- cp -rt ${_dest} client/ server/
+ install -Dt "${_dest}" "${pkgname}-client" "${pkgname}-server"
+
+ cd "${_name}"
+ install -d "${_dest}"
+ cp -rt "${_dest}" client/ server/
+
}
diff --git a/tachyons-client b/tachyons-client
new file mode 100755
index 000000000000..71cbeaaa3b00
--- /dev/null
+++ b/tachyons-client
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd /opt/tachyons/client/
+/usr/lib/jvm/java-8-openjdk/jre/bin/java -jar Tachyons.jar
diff --git a/tachyons-server b/tachyons-server
new file mode 100755
index 000000000000..2fe6e3a72755
--- /dev/null
+++ b/tachyons-server
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd /opt/tachyons/server/
+/usr/lib/jvm/java-8-openjdk/jre/bin/java -jar TachyonsServer.jar