summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2015-12-27 23:24:36 +0100
committerMartchus2015-12-27 23:24:36 +0100
commitd718361bcd995d021d214bba3a52192042047ac0 (patch)
tree1d292089a48f7af4f3aaa29727289d8ab6946ef7
parentdec626dd3d5ab7ea42bd30465d87d0147b47544a (diff)
downloadaur-d718361bcd995d021d214bba3a52192042047ac0.tar.gz
updated version
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD25
-rw-r--r--tageditor.install8
3 files changed, 19 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49ca944a1b57..07a752246bf4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
+# Generated by mksrcinfo v8
+# Sun Dec 27 22:05:25 UTC 2015
pkgbase = tageditor
pkgdesc = A tag editor with Qt GUI and command-line interface supporting MP4 (iTunes), ID3, Vorbis and Matroska.
- pkgver = 1.2.1
+ pkgver = 1.3.0
pkgrel = 1
url = https://github.com/Martchus/tageditor
install = tageditor.install
arch = i686
arch = x86_64
license = GPL
+ makedepends = cmake
makedepends = qt5-tools
depends = qt5-script
depends = qt5-webkit
@@ -14,8 +17,8 @@ pkgbase = tageditor
depends = tagparser
depends = desktop-file-utils
depends = xdg-utils
- source = tageditor-1.2.1.tar.gz::https://github.com/Martchus/tageditor/archive/v1.2.1.tar.gz
- sha256sums = d089b9e66616c39147b639639152c5848f59dafa2c0a9a77d0137fbed13a2af9
+ source = tageditor-1.3.0.tar.gz::https://github.com/Martchus/tageditor/archive/v1.3.0.tar.gz
+ sha256sums = 6b050fe5281b0be7dba02783e86dfb93c781c8271be949e81371113905db1312
pkgname = tageditor
diff --git a/PKGBUILD b/PKGBUILD
index 1e48944a06e8..59f779033e2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,25 @@
# Maintainer: Martchus <martchus@gmx.net>
-# decide whether to link against the deprecated Qt WebKit module (in qt5-webkit package ~40 MB) or
-# the newer, chromium-based Qt WebEngine module (in qt5-webengine package ~100 MB)
-_webviewprovider=qt5-webkit
_reponame=tageditor
pkgname=tageditor
-pkgver=1.2.1
+pkgver=1.3.0
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="A tag editor with Qt GUI and command-line interface supporting MP4 (iTunes), ID3, Vorbis and Matroska."
license=('GPL')
-depends=('qt5-script' $_webviewprovider 'qtutilities' 'tagparser' 'desktop-file-utils' 'xdg-utils')
-makedepends=('qt5-tools')
+depends=('qt5-script' 'qt5-webkit' 'qtutilities' 'tagparser' 'desktop-file-utils' 'xdg-utils')
+makedepends=('cmake' 'qt5-tools')
install=${pkgname}.install
url="https://github.com/Martchus/${_reponame}"
source=("tageditor-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
-sha256sums=('d089b9e66616c39147b639639152c5848f59dafa2c0a9a77d0137fbed13a2af9')
+sha256sums=('6b050fe5281b0be7dba02783e86dfb93c781c8271be949e81371113905db1312')
build() {
- cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
- cfg=()
- if [[ _webviewprovider == qt5-webkit ]]; then
- cfg+=(forcewebkit)
- fi
- INSTALL_ROOT=$pkgdir/usr/ qmake-qt5 "$pkgname.pro" $(for val in "${cfg[@]}"; do echo -n "CONFIG+=$val "; done)
- make
+ cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr"
+ make
}
package() {
- cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
- make install
+ cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
+ make install
}
diff --git a/tageditor.install b/tageditor.install
index 5495fb1b5d27..5c501dc49916 100644
--- a/tageditor.install
+++ b/tageditor.install
@@ -1,12 +1,12 @@
post_install() {
- xdg-icon-resource forceupdate --theme hicolor &> /dev/null
- update-desktop-database -q
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
}
post_upgrade() {
- post_install
+ post_install
}
post_remove() {
- post_install
+ post_install
}