summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2024-02-28 15:04:22 +0100
committerMartchus2024-02-28 15:04:22 +0100
commit091018e4ad20508349b688962d21a10dc25252e9 (patch)
treebde1a54d3fc52943be1957695f28f892f4780bc5
parent38ba0b309daa08235a31bf218d79fb491cdb5857 (diff)
downloadaur-tageditor-git.tar.gz
Use Qt 6
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6657f6643005..9c905e569356 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tageditor-git
pkgdesc = A tag editor with Qt GUI and command-line interface supporting MP4/M4A/AAC (iTunes), ID3, Vorbis, Opus, FLAC and Matroska
pkgver = 719.9599560
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/Martchus/tageditor
arch = i686
arch = x86_64
@@ -12,21 +12,22 @@ pkgbase = tageditor-git
checkdepends = cppunit
checkdepends = jq
makedepends = cmake
- makedepends = qt5-tools
+ makedepends = qt6-tools
makedepends = git
makedepends = ninja
+ makedepends = clang
+ makedepends = qt6-declarative
makedepends = reflective-rapidjson-git
depends = libqtutilities-git.so
depends = libtagparser-git.so
depends = libc++utilities-git.so
depends = desktop-file-utils
depends = xdg-utils
- depends = qt5-webengine
- depends = qt5-declarative
+ depends = qt6-webengine
+ depends = qt6-declarative
provides = tageditor
conflicts = tageditor
source = tageditor::git+https://github.com/Martchus/tageditor.git
sha256sums = SKIP
pkgname = tageditor-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 9a1a97d1900b..76feacfe32f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,17 +16,17 @@ _reponame=tageditor
pkgname=tageditor-git
_name=${pkgname%-git}
pkgver=719.9599560
-pkgrel=3
+pkgrel=4
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
pkgdesc='A tag editor with Qt GUI and command-line interface supporting MP4/M4A/AAC (iTunes), ID3, Vorbis, Opus, FLAC and Matroska'
license=('GPL')
depends=('libqtutilities-git.so' 'libtagparser-git.so' 'libc++utilities-git.so' 'desktop-file-utils' 'xdg-utils')
-[[ $_webview_provider == none ]] && [[ $_js_provider == none ]] && depends+=('qt5-base')
-[[ $_webview_provider == webkit ]] && depends+=('qt5-webkit')
-[[ $_webview_provider == webengine ]] && depends+=('qt5-webengine')
-[[ $_js_provider == script ]] && depends+=('qt5-script')
-[[ $_js_provider == qml ]] && depends+=('qt5-declarative')
-makedepends=('cmake' 'qt5-tools' 'git' 'ninja')
+[[ $_webview_provider == none ]] && [[ $_js_provider == none ]] && depends+=('qt6-base')
+[[ $_webview_provider == webkit ]] && depends+=('qt6-webkit')
+[[ $_webview_provider == webengine ]] && depends+=('qt6-webengine')
+[[ $_js_provider == script ]] && depends+=('qt6-script')
+[[ $_js_provider == qml ]] && depends+=('qt6-declarative')
+makedepends=('cmake' 'qt6-tools' 'git' 'ninja' 'clang' 'qt6-declarative')
[[ $_json_export == ON ]] && makedepends+=('reflective-rapidjson-git')
checkdepends=('cppunit' 'jq')
provides=("${_name}")
@@ -48,6 +48,8 @@ build() {
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
-DCONFIGURATION_NAME:STRING='git' \
-DCONFIGURATION_PACKAGE_SUFFIX:STRING='-git' \
+ -DQT_PACKAGE_PREFIX:STRING='Qt6' \
+ -DKF_PACKAGE_PREFIX:STRING='KF6' \
-DBUILD_SHARED_LIBS:BOOL=ON \
-DWEBVIEW_PROVIDER="${_webview_provider}" \
-DJS_PROVIDER="${_js_provider}" \