summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorΝικόλαος Κυριάκος Φυτίλης2016-10-28 20:53:35 +0300
committerΝικόλαος Κυριάκος Φυτίλης2016-10-28 20:53:35 +0300
commit7634584076d90103c75f670ee915882825438b8f (patch)
tree32a53764f528b66e00673ddc040bd3b7b4b7623f
downloadaur-7634584076d90103c75f670ee915882825438b8f.tar.gz
init
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5061f5f5c56e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = taglib-sharp-git
+ pkgdesc = Library for reading and writing metadata in media files for Mono - source from git for working opus files
+ pkgver = taglib.sharp.2.1.0.0.r69.gf8d6334
+ pkgrel = 1
+ url = https://github.com/mono/taglib-sharp
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ depends = mono
+ provides = taglib-sharp
+ conflicts = taglib-sharp
+ source = git+https://github.com/mono/taglib-sharp.git
+ md5sums = SKIP
+
+pkgname = taglib-sharp-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..53a34eee857e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+taglib-sharp
+taglib-sharp-taglib.sharp.2.1.0.0.r69.gf8d6334-1-x86_64.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77e24f5a2cc6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id: PKGBUILD 203202 2014-01-05 10:51:18Z bpiotrowski $
+# Maintainer: Nikos Fytilis <n-fit@live.com>
+# Repo Maintainer: Daniel Isenmann <daniel@archlinux.org>
+# Contributor: Carlos Ruiz <cailovirtual@gmail.com>
+
+_pkgbase=taglib-sharp
+pkgname=$_pkgbase-git
+pkgver=taglib.sharp.2.1.0.0.r69.gf8d6334
+pkgrel=1
+pkgdesc="Library for reading and writing metadata in media files for Mono - source from git for working opus files"
+arch=('i686' 'x86_64')
+url="https://github.com/mono/taglib-sharp"
+license=('LGPL2.1')
+depends=('mono')
+conflicts=(taglib-sharp)
+provides=(taglib-sharp)
+source=(git+https://github.com/mono/taglib-sharp.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgbase"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_pkgbase"
+ ./autogen.sh --prefix=/usr --disable-docs
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgbase"
+ make DESTDIR=${pkgdir} install
+}