summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenjiTakahashi2015-07-31 23:02:16 +0200
committerKenjiTakahashi2015-07-31 23:02:16 +0200
commit48fc4e5aa18a522a0d832f7fe3a630811cac69e6 (patch)
treee8d379a17b2debb441f0671ed94f54dd2571f18a
downloadaur-48fc4e5aa18a522a0d832f7fe3a630811cac69e6.tar.gz
3.0.2-1: Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD39
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a1d62cffb7f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = tagutil
+ pkgdesc = scriptable music files tags tool and editor
+ pkgver = 3.0.2
+ pkgrel = 1
+ url = https://github.com/kAworu/tagutil
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = cmake
+ depends = libyaml
+ depends = taglib
+ depends = flac
+ depends = libvorbis
+ depends = jansson
+ options = !emptydirs
+ source = https://github.com/kAworu/tagutil/archive/v3.0.2.tar.gz
+ md5sums = 5d434c7aa174b8d4a1b76e01b8bcd2a1
+
+pkgname = tagutil
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f0c6a929287
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Karol "Kenji Takahashi" Woźniak <kenji.sx>
+# Contributor: Rolinh <robinDOThahlingATgw-computingDOTnet>
+
+pkgname=tagutil
+pkgver=3.0.2
+pkgrel=1
+pkgdesc="scriptable music files tags tool and editor"
+arch=('i686' 'x86_64')
+url="https://github.com/kAworu/tagutil"
+license=('BSD')
+depends=(
+ 'libyaml'
+ 'taglib'
+ 'flac'
+ 'libvorbis'
+ 'jansson'
+)
+makedepends=(
+ 'cmake'
+)
+options=(!emptydirs)
+source=("${url}/archive/v${pkgver}.tar.gz")
+md5sums=('5d434c7aa174b8d4a1b76e01b8bcd2a1')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+
+ cmake . -DPREFIX=/usr -DCMAKE_BUILD_TYPE=RELEASE
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/"${pkgname}"/LICENSE"
+}
+
+# vim:set ts=4 sw=4 et: