summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Fung2022-01-16 02:29:03 -0800
committerEric Fung2022-01-16 02:29:03 -0800
commit0f5c59da34f1fc414be2c4c85f5e2a57716a23be (patch)
tree9720788d04613ee21f5e655a84a75a0193d3f5d7
parent243231109ce44b236fdb1538f8a8c9650f680e86 (diff)
downloadaur-0f5c59da34f1fc414be2c4c85f5e2a57716a23be.tar.gz
Updated to 1.17.1, dropped Python2, added all new Python3 dependencies
-rw-r--r--.SRCINFO60
-rw-r--r--PKGBUILD88
2 files changed, 56 insertions, 92 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98fb9394f1b5..11f127519d3d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,44 +1,30 @@
pkgbase = tahoe-lafs
- pkgdesc = Secure, decentralized, and fault-tolerant filesystem.
- pkgver = 1.13.0
- pkgrel = 3
+ pkgdesc = Secure, decentralized, and fault-tolerant storage system.
+ pkgver = 1.17.1
+ pkgrel = 1
url = https://tahoe-lafs.org/trac/tahoe-lafs
arch = any
license = GPL
- depends = openssl>=1.0.2
- depends = python2-twisted>=16.1.0
- depends = python2-pyopenssl>=0.14
- depends = python2-pyasn1>=0.1.8
- depends = python2-pyasn1-modules>=0.0.5
- depends = python2-zope-interface>=4.0.5
- depends = python2-characteristic>=14.3.0
- depends = python2-service-identity>=14.0.0
- depends = python2-cryptography
- depends = python2-pyutil>=1.9.4
- depends = python2-simplejson>=3.1.3
- depends = nevow>=0.12.0
- depends = python2-zbase32>=1.1.5
- depends = python2-zfec>=1.4.24
- depends = pycryptopp>=0.6.0
- depends = python2-cffi
- depends = python2-enum34
- depends = python2-pycparser
- depends = python2-six
- depends = libffi
- depends = python2-foolscap>=0.12.6
- depends = net-tools
- depends = python2-setuptools
- depends = python2-shutilwhich>=1.1.0
- depends = python2-yaml
- depends = python2-pycryptodome
- optdepends = python2-numpy: reliability test
- conflicts = tahoe-lafs-i2p
- replaces = tahoe-lafs-i2p
- source = https://tahoe-lafs.org/downloads/tahoe-lafs-1.13.0.tar.bz2
- source = https://tahoe-lafs.org/downloads/tahoe-lafs-1.13.0.tar.bz2.asc
- validpgpkeys = E34E62D06D0E69CFCA4179FFBDE0D31D68666A7A
- sha256sums = 82d4d20f2672e67927d91e73e54dbfd7e526eca27dea09a29f131bef7dfaee86
+ license = custom
+ depends = magic-wormhole
+ depends = python-argparse
+ depends = python-bcrypt
+ depends = python-boltons
+ depends = python-cbor2
+ depends = python-collections-extended
+ depends = python-eliot
+ depends = python-foolscap
+ depends = python-future
+ depends = python-klein
+ depends = python-netifaces
+ depends = python-pyrsistent
+ depends = python-treq
+ depends = python-yaml
+ depends = python-zfec
+ source = https://tahoe-lafs.org/downloads/tahoe-lafs-1.17.1.tar.gz
+ source = https://tahoe-lafs.org/downloads/tahoe-lafs-1.17.1.tar.gz.asc
+ validpgpkeys = 9D5A2BD5688ECB889DEBCD3FC2602803128069A7
+ sha256sums = 2dc7fc103fe0e4f9fc69953934089f55e4428bd5d94670e844e64c210d7c1672
sha256sums = SKIP
pkgname = tahoe-lafs
-
diff --git a/PKGBUILD b/PKGBUILD
index f7d8a8ec7e75..068615058bb9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,71 +1,49 @@
-# Maintainer: GI_Jack <GI_Jack@hackermail.com>
-# Old Maintainer : Skydrome <skydrome@i2pmail.org>
+# Contributor: Eric Fung <loseurmarbles at gmail dot com>
+# Contributor: GI_Jack <GI_Jack@hackermail.com>
+# Contributor: Skydrome <skydrome@i2pmail.org>
# Contributor: DaNiMoTh <jjdanimoth@gmail.com>
# Contributor (Arch): Peter Simons <simons@cryp.to>
# Contributor (Arch): Nicolas Pouillard <nicolas.pouillard@gmail.com>
pkgname=tahoe-lafs
-pkgver=1.13.0
-pkgrel=3
-pkgdesc="Secure, decentralized, and fault-tolerant filesystem."
+pkgver=1.17.1
+pkgrel=1
+pkgdesc='Secure, decentralized, and fault-tolerant storage system.'
url='https://tahoe-lafs.org/trac/tahoe-lafs'
-license=('GPL')
+license=('GPL' 'custom')
arch=('any')
-conflicts=('tahoe-lafs-i2p')
-replaces=('tahoe-lafs-i2p')
-BUILDENV+=(!check)
-
-depends=('openssl>=1.0.2'
- 'python2-twisted>=16.1.0'
- 'python2-pyopenssl>=0.14'
- 'python2-pyasn1>=0.1.8'
- 'python2-pyasn1-modules>=0.0.5'
- 'python2-zope-interface>=4.0.5'
- 'python2-characteristic>=14.3.0'
- 'python2-service-identity>=14.0.0'
- 'python2-cryptography'
- 'python2-pyutil>=1.9.4'
- 'python2-simplejson>=3.1.3'
- 'nevow>=0.12.0'
- 'python2-zbase32>=1.1.5'
- 'python2-zfec>=1.4.24'
- 'pycryptopp>=0.6.0'
- 'python2-cffi'
- 'python2-enum34'
- 'python2-pycparser'
- 'python2-six'
- 'libffi'
- 'python2-foolscap>=0.12.6'
- 'net-tools' # provides /sbin/ifconfig
- 'python2-setuptools'
- 'python2-shutilwhich>=1.1.0'
- 'python2-yaml'
- 'python2-pycryptodome')
-
-optdepends=('python2-numpy: reliability test')
-
-source=("https://tahoe-lafs.org/downloads/tahoe-lafs-$pkgver.tar.bz2"
- "https://tahoe-lafs.org/downloads/tahoe-lafs-$pkgver.tar.bz2.asc")
-
-# https://tahoe-lafs.org/downloads/tahoe-release-signing-gpg-key.asc
-sha256sums=('82d4d20f2672e67927d91e73e54dbfd7e526eca27dea09a29f131bef7dfaee86'
+depends=('magic-wormhole'
+ 'python-argparse'
+ 'python-bcrypt'
+ 'python-boltons'
+ 'python-cbor2'
+ 'python-collections-extended'
+ 'python-eliot'
+ 'python-foolscap'
+ 'python-future'
+ 'python-klein'
+ 'python-netifaces'
+ 'python-pyrsistent'
+ 'python-treq'
+ 'python-yaml'
+ 'python-zfec')
+# python-boltons is for python-eliot until the maintainer adds it.
+
+source=(https://tahoe-lafs.org/downloads/tahoe-lafs-${pkgver}.tar.gz{,.asc})
+
+sha256sums=('2dc7fc103fe0e4f9fc69953934089f55e4428bd5d94670e844e64c210d7c1672'
'SKIP')
-validpgpkeys=('E34E62D06D0E69CFCA4179FFBDE0D31D68666A7A')
-
-build(){
- cd "${srcdir}/tahoe-lafs-${pkgver}"
- python2 setup.py build
-}
+validpgpkeys=('9D5A2BD5688ECB889DEBCD3FC2602803128069A7')
+# https://meejah.ca/about/gnupg
-check() {
+build() {
cd "${srcdir}/tahoe-lafs-${pkgver}"
- msg "This may take a while"
- python2 bin/tahoe debug trial $MAKEFLAGS
+ python setup.py build
}
-package(){
+package() {
cd "${srcdir}/tahoe-lafs-${pkgver}"
- python2 setup.py install --root="$pkgdir" --optimize=1
+ python setup.py install --root="${pkgdir}" --optimize=1
install -Dm644 COPYING.GPL "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}