summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormutantmonkey2015-01-18 15:58:08 -0800
committermutantmonkey2015-01-18 15:58:08 -0800
commitcdb630e7b9cdd2771a2a706b51e426665f53bbff (patch)
treeaa8d50c9cbd85e83acca47d7ef4b6b0e86ef9801
downloadaur-cdb630e7b9cdd2771a2a706b51e426665f53bbff.tar.gz
add tahoe-lafs-git package
-rw-r--r--.SRCINFO34
-rw-r--r--0001-auto_deps-Workaround-dep-resolution-issue.patch48
-rw-r--r--PKGBUILD50
3 files changed, 132 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f92fbf645fb0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = tahoe-lafs-git
+ pkgdesc = A secure, decentralized, fault-tolerant file store (git version)
+ pkgver = 6110.9d60033
+ pkgrel = 1
+ url = https://tahoe-lafs.org/
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = net-tools
+ depends = python2
+ depends = python2-zope-interface>=3.6.5
+ depends = twisted
+ depends = python2-pyasn1
+ depends = python2-crypto
+ depends = pycryptopp
+ depends = nevow
+ depends = python2-foolscap>=0.8.0
+ depends = python2-simplejson
+ depends = zfec
+ depends = python2-pyopenssl
+ depends = pyutil
+ depends = python2-argparse
+ depends = zbase32
+ depends = python2-mock>=0.8.0
+ depends = python2-characteristic>=14.0
+ depends = python2-service-identity
+ depends = python2-setuptools
+ provides = tahoe-lafs
+ conflicts = tahoe-lafs
+ source = git+https://github.com/tahoe-lafs/tahoe-lafs.git
+ sha256sums = SKIP
+
+pkgname = tahoe-lafs-git
+
diff --git a/0001-auto_deps-Workaround-dep-resolution-issue.patch b/0001-auto_deps-Workaround-dep-resolution-issue.patch
new file mode 100644
index 000000000000..1f58cf9de090
--- /dev/null
+++ b/0001-auto_deps-Workaround-dep-resolution-issue.patch
@@ -0,0 +1,48 @@
+From f31b684f0278b7d8cd7fb8a2ad4b67e8aec8fcc8 Mon Sep 17 00:00:00 2001
+From: Kyle Manna <kyle@kylemanna.com>
+Date: Sun, 18 Jan 2015 23:43:29 +0000
+Subject: [PATCH] auto_deps: Workaround dep resolution issue
+
+Errors:
+
+ tahoe[5580]: Traceback (most recent call last):
+ tahoe[5580]: File "/usr/bin/tahoe", line 6, in <module>
+ tahoe[5580]: from pkg_resources import load_entry_point
+ tahoe[5580]: File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2951, in <module>
+ tahoe[5580]: working_set = WorkingSet._build_master()
+ tahoe[5580]: File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 563, in _build_master
+ tahoe[5580]: return cls._build_from_requirements(__requires__)
+ tahoe[5580]: File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 576, in _build_from_requirements
+ tahoe[5580]: dists = ws.resolve(reqs, Environment())
+ tahoe[5580]: File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 755, in resolve
+ tahoe[5580]: raise DistributionNotFound(req)
+ tahoe[5580]: pkg_resources.DistributionNotFound: pycrypto==2.1.0,==2.3,>=2.4.1
+---
+ src/allmydata/_auto_deps.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/allmydata/_auto_deps.py b/src/allmydata/_auto_deps.py
+index 5052ab8..9f698eb 100644
+--- a/src/allmydata/_auto_deps.py
++++ b/src/allmydata/_auto_deps.py
+@@ -16,7 +16,7 @@ install_requires = [
+
+ # zope.interface >= 3.6.0 is required for Twisted >= 12.1.0.
+ # zope.interface 3.6.3 and 3.6.4 are incompatible with Nevow (#1435).
+- "zope.interface == 3.6.0, == 3.6.1, == 3.6.2, >= 3.6.5",
++ "zope.interface >= 3.6.5",
+
+ # * foolscap < 0.5.1 had a performance bug which spent O(N**2) CPU for
+ # transferring large mutable files of size N.
+@@ -28,7 +28,7 @@ install_requires = [
+ # Needed for SFTP.
+ # pycrypto 2.2 doesn't work due to <https://bugs.launchpad.net/pycrypto/+bug/620253>
+ # pycrypto 2.4 doesn't work due to <https://bugs.launchpad.net/pycrypto/+bug/881130>
+- "pycrypto == 2.1.0, == 2.3, >= 2.4.1",
++ "pycrypto >= 2.4.1",
+
+ # <http://www.voidspace.org.uk/python/mock/>, 0.8.0 provides "call"
+ "mock >= 0.8.0",
+--
+2.2.2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91feab172760
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor (Arch): Peter Simons <simons@cryp.to>
+# Contributor (Arch): Nicolas Pouillard <nicolas.pouillard@gmail.com>
+# Maintainer: mutantmonkey <aur@mutantmonkey.in>
+pkgname=tahoe-lafs-git
+pkgver=5971.f77f358
+pkgrel=2
+pkgdesc="A secure, decentralized, fault-tolerant file store (git version)"
+url="https://tahoe-lafs.org/"
+arch=('any')
+license=('GPL')
+depends=('net-tools' 'python2' 'python2-zope-interface>=3.6.5' 'twisted'
+ 'python2-pyasn1' 'python2-crypto' 'pycryptopp' 'nevow'
+ 'python2-foolscap' 'python2-simplejson' 'zfec' 'python2-pyopenssl'
+ 'pyutil' 'python2-argparse' 'zbase32' 'python2-mock>=0.8.0'
+ 'python2-characteristic>=14.0' 'python2-service-identity'
+ 'python2-setuptools')
+makedepends=('git')
+provides=('tahoe-lafs')
+conflicts=('tahoe-lafs')
+source=('git+https://github.com/tahoe-lafs/tahoe-lafs.git'
+ '0001-auto_deps-Workaround-dep-resolution-issue.patch')
+sha256sums=('SKIP'
+ '2f43e98fc44a3597e28fd46de9c7b06e2aeedf62dc41fe9dcd18de03266ec915')
+
+pkgver() {
+ cd "$srcdir/tahoe-lafs"
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+prepare() {
+ cd "$srcdir/tahoe-lafs"
+ patch -p1 -i ../0001-auto_deps-Workaround-dep-resolution-issue.patch
+}
+
+build() {
+ cd "$srcdir/tahoe-lafs"
+ python2 setup.py build
+}
+
+check() {
+ cd "$srcdir/tahoe-lafs"
+ python2 setup.py test
+}
+
+package() {
+ cd "$srcdir/tahoe-lafs"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: