summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorskydrome2015-06-18 13:01:33 -0400
committerskydrome2015-06-18 13:01:33 -0400
commitc971a1d2128e9453ebc74950b744c42e1e249bd8 (patch)
treea4c69995097200287e32842fe47c805be488f58e
parent03ade2c6d2081db810aa7b6e84cafa3723fe3fcb (diff)
downloadaur-c971a1d2128e9453ebc74950b744c42e1e249bd8.tar.gz
modified: PKGBUILD
new file: customize_setupcfg_aliases.patch modified: exclude_buildtest_package.patch
-rwxr-xr-xPKGBUILD22
-rw-r--r--customize_setupcfg_aliases.patch20
-rw-r--r--[-rwxr-xr-x]exclude_buildtest_package.patch26
3 files changed, 43 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5a4a1181fb25..1d4b860230c3 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgver=1.10.0.post26
_patchver=1.10.0-r0
pkgrel=2
pkgdesc="Secure, decentralized, and fault-tolerant filesystem over the I2P network"
-url='http://tahoe-lafs.org'
+url='https://tahoe-lafs.org/trac/tahoe-lafs'
license=('GPL')
arch=('any')
conflicts=('tahoe-lafs')
@@ -36,8 +36,7 @@ depends=('openssl>=1.0.2'
'libffi'
'python2-foolscap-i2p'
'net-tools' # provides /sbin/ifconfig
- 'python2-setuptools'
- )
+ 'python2-setuptools')
optdepends=('grid-updates: helps keep you up to date with latest grid news'
'python2-numpy: reliability test')
@@ -47,26 +46,23 @@ source=("https://tahoe-lafs.org/source/tahoe-lafs/tarballs/allmydata-tahoe-${pkg
#'0001-multiple-introducer-support.patch'
#'0002-proxy-support.patch'
#'0003-allow-non-routable.patch'
+ 'customize_setupcfg_aliases.patch'
'exclude_buildtest_package.patch'
"http://killyourtv.i2p.me/tahoe-lafs/patches/tahoe-lafs-i2p-${_patchver}.patch"
'tahoe-repair-all.sh')
sha256sums=('542830908e6deb66767ef98271bcf067f9787c0013b764caae23c7649b4f3171'
'b410d6276466f9feb270ae3e27bc7bc1901effc5132a089ff88a98b7efe6895e'
- '469aa0ace523b64449e7d2d52958119a84032c50b07828b3dffbb81dca5327bd'
+ 'df6a6796cc599fc60da4a25d86d7c2806df6a6ebc1850b117dd19b09ea7d9f8e'
+ '0cd7ae573726b79922bead80fec2367f64805bcbf1cebeda6d6a3fb3af13c983'
'425456a08477da50ef1511ea1b24cc6a529c4abaae345a3da89a31c025d74b80'
'1525fd5c2ac2c93844f23160e70bb47040a9a8ee7dff8b6fff8ca48b374ac216')
-
prepare() {
cd "${srcdir}/allmydata-tahoe-${pkgver}"
- patch -Np1 -i ../setuptools_fix.patch
- if [[ ! -r "${srcdir}/tahoe-lafs-i2p-${_patchver}.patch" ]]; then
- for p in $(ls ${srcdir}/*.patch); do
- patch -Np1 -i $p
- done
- else
- patch -Np1 -i "${srcdir}/tahoe-lafs-i2p-${_patchver}.patch"
- fi
+ for p in ${srcdir}/*.patch; do
+ msg "$(basename $p)"
+ patch -Np1 -i "$p"
+ done
}
build(){
diff --git a/customize_setupcfg_aliases.patch b/customize_setupcfg_aliases.patch
new file mode 100644
index 000000000000..158f101359f9
--- /dev/null
+++ b/customize_setupcfg_aliases.patch
@@ -0,0 +1,20 @@
+Description: Customize upstream's defined setup.py aliases.
+ We don't need some of the setup.py options defined in setup.cfg by upstream in
+ the Debian package context.
+Forwarded: not-needed
+Author: bertagaz <bertagaz@ptitcanardnoir.org>
+Index: tahoe.git/setup.cfg
+===================================================================
+--- tahoe.git.orig/setup.cfg 2013-10-09 14:41:43.909073001 +0200
++++ tahoe.git/setup.cfg 2013-10-10 14:05:43.673073382 +0200
+@@ -5,8 +5,8 @@
+ https://tahoe-lafs.org/source/tahoe-lafs/deps/tahoe-lafs-dep-eggs/
+
+ [aliases]
+-build = update_version develop --prefix=support make_executable build
+-test = update_version develop --prefix=support make_executable build trial
++build = update_version make_executable build
++test = update_version develop make_executable build trial
+ sdist = update_version sdist
+ install = update_version install
+ bdist_egg = update_version bdist_egg
diff --git a/exclude_buildtest_package.patch b/exclude_buildtest_package.patch
index c28b331ba08d..daadeb7f2fc9 100755..100644
--- a/exclude_buildtest_package.patch
+++ b/exclude_buildtest_package.patch
@@ -1,25 +1,27 @@
+Description: Exclude buildtest python package from Debian package.
By default tahoe-lafs also install a buildtest package but this isn't relevant
in the context of the Debian package.
+Forwarded: not-needed
Author: bertagaz <bertagaz@ptitcanardnoir.org>
-Index: tahoe/setup.py
+Index: tahoe.git/setup.py
===================================================================
---- tahoe.orig/setup.py 2012-07-04 21:42:07.000000000 +0200
-+++ tahoe/setup.py 2012-07-04 21:59:45.051169297 +0200
-@@ -467,8 +467,7 @@
- 'allmydata.util',
+--- tahoe.git.orig/setup.py 2013-09-03 19:04:12.745099226 +0200
++++ tahoe.git/setup.py 2013-09-03 19:04:24.637106872 +0200
+@@ -436,8 +436,7 @@
'allmydata.web',
'allmydata.web.static',
+ 'allmydata.web.static.css',
- 'allmydata.windows',
- 'buildtest'],
+ 'allmydata.windows'],
classifiers=trove_classifiers,
test_suite="allmydata.test",
install_requires=install_requires,
-Index: tahoe/src/allmydata_tahoe.egg-info/SOURCES.txt
+Index: tahoe.git/src/allmydata_tahoe.egg-info/SOURCES.txt
===================================================================
---- tahoe.orig/src/allmydata_tahoe.egg-info/SOURCES.txt 2012-07-04 21:41:43.000000000 +0200
-+++ tahoe/src/allmydata_tahoe.egg-info/SOURCES.txt 2012-07-04 21:59:25.615659017 +0200
-@@ -431,7 +431,5 @@
+--- tahoe.git.orig/src/allmydata_tahoe.egg-info/SOURCES.txt 2013-09-03 19:00:55.393107907 +0200
++++ tahoe.git/src/allmydata_tahoe.egg-info/SOURCES.txt 2013-09-03 19:04:12.753100409 +0200
+@@ -422,7 +422,5 @@
src/allmydata_tahoe.egg-info/not-zip-safe
src/allmydata_tahoe.egg-info/requires.txt
src/allmydata_tahoe.egg-info/top_level.txt
@@ -29,10 +31,10 @@ Index: tahoe/src/allmydata_tahoe.egg-info/SOURCES.txt
-twisted/plugins/allmydata_trial.py
\ No newline at end of file
+twisted/plugins/allmydata_trial.py
-Index: tahoe/src/allmydata_tahoe.egg-info/top_level.txt
+Index: tahoe.git/src/allmydata_tahoe.egg-info/top_level.txt
===================================================================
---- tahoe.orig/src/allmydata_tahoe.egg-info/top_level.txt 2012-07-04 21:41:43.295659068 +0200
-+++ tahoe/src/allmydata_tahoe.egg-info/top_level.txt 2012-07-04 21:59:25.615659017 +0200
+--- tahoe.git.orig/src/allmydata_tahoe.egg-info/top_level.txt 2013-09-03 19:00:55.393107907 +0200
++++ tahoe.git/src/allmydata_tahoe.egg-info/top_level.txt 2013-09-03 19:04:12.753100409 +0200
@@ -1,2 +1 @@
allmydata
-buildtest