summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2021-08-22 15:42:32 +0200
committerFabioLolix2021-08-22 15:42:32 +0200
commit694f6f0fa37f7f618427bd5c2e5c1ec7821fbec0 (patch)
tree3cb74deb2f0baa2d29b2058712fefc0e6141d355
downloadaur-694f6f0fa37f7f618427bd5c2e5c1ec7821fbec0.tar.gz
upload
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD45
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a25c92a200b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = tahoma2d
+ pkgdesc = Software for producing a 2D animation
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://tahoma2d.org/
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = boost
+ makedepends = cmake
+ makedepends = qt5-tools
+ depends = cblas
+ depends = ffmpeg
+ depends = freeglut
+ depends = glew
+ depends = hicolor-icon-theme
+ depends = libmypaint
+ depends = qt5-multimedia
+ depends = qt5-script
+ depends = qt5-svg
+ depends = qt5-serialport
+ depends = superlu
+ depends = opencv
+ provides = tahoma2d
+ conflicts = tahoma2d
+ source = git+https://github.com/tahoma2d/tahoma2d.git#tag=v1.2
+ sha256sums = SKIP
+
+pkgname = tahoma2d
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4cdafe266cba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Campbell Barton <ideasman42@gmail.com>
+
+export GIT_LFS_SKIP_SMUDGE=1
+
+pkgname=tahoma2d
+pkgver=1.2
+pkgrel=1
+pkgdesc="Software for producing a 2D animation"
+arch=(x86_64)
+url="https://tahoma2d.org/"
+license=(BSD)
+depends=(cblas ffmpeg freeglut glew hicolor-icon-theme libmypaint qt5-multimedia qt5-script qt5-svg qt5-serialport superlu opencv)
+makedepends=(git boost cmake qt5-tools)
+provides=(tahoma2d)
+conflicts=(tahoma2d)
+source=("git+https://github.com/tahoma2d/tahoma2d.git#tag=v${pkgver}")
+sha256sums=('SKIP')
+
+prepare() {
+ [[ -d build ]] || mkdir build
+
+ cd "${pkgname%-git}"
+ # Specify path for ffmpeg
+ #sed -i 's|"ffmpegPath", QMetaType::QString, ""|"ffmpegPath", QMetaType::QString, "/usr/bin"|' toonz/sources/toonzlib/preferences.cpp
+}
+
+build() {
+ pushd "${pkgname%-git}/thirdparty/tiff-4.0.3"
+ ./configure --with-pic --disable-jbig
+ make
+ popd
+
+ cd build
+ cmake -G "Unix Makefiles" ../"${pkgname%-git}"/toonz/sources \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_SKIP_RPATH=YES
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 ../"${pkgname%-git}"/LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+}