summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Anderson2020-03-12 19:04:30 -0700
committerDavid Anderson2020-03-12 19:04:30 -0700
commit2e89f97f7f76be8cb37d50ac4d2a32665e5f45bc (patch)
tree58771320d00b37cd28d3a306c4293fed61cedde4
parent5e76c573ab106d4e8d7b50d94d3b63b206f35957 (diff)
downloadaur-2e89f97f7f76be8cb37d50ac4d2a32665e5f45bc.tar.gz
start/stop/restart tailscaled.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rwxr-xr-xtailscale.install20
3 files changed, 18 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ce159bcff49..6789ad2d5fcf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tailscale
pkgdesc = A mesh VPN that makes it easy to connect your devices, wherever they are.
pkgver = 0.96_0
- pkgrel = 1
+ pkgrel = 2
url = https://tailscale.com
install = tailscale.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index d50cbdb65dd7..a6746c36d0d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname="tailscale"
_version="0.96-0"
pkgver="0.96_0"
-pkgrel="1"
+pkgrel="2"
pkgdesc="A mesh VPN that makes it easy to connect your devices, wherever they are."
arch=("x86_64")
url="https://tailscale.com"
diff --git a/tailscale.install b/tailscale.install
index 8859a3a764aa..2d72ba28e1dd 100755
--- a/tailscale.install
+++ b/tailscale.install
@@ -1,13 +1,25 @@
# -*- mode: shell-script -*-
post_install() {
+ usr/bin/systemctl daemon-reload
+ usr/bin/systemctl enable tailscaled.service
+ usr/bin/systemctl start tailscaled.service
+
echo -e "\n\e[1m Tailscale $1\e[0m\n"
cat <<EOF
-To start using Tailscale, start tailscaled and log in:
+To start using Tailscale, log in with:
- systemctl enable tailscaled
- systemctl start tailscaled
- tailscale up
+ sudo tailscale up
EOF
}
+
+post_upgrade() {
+ usr/bin/systemctl daemon-reload
+ usr/bin/systemctl restart tailscaled.service
+}
+
+pre_remove() {
+ usr/bin/systemctl stop tailscaled.service
+ usr/bin/systemctl disable tailscaled.service
+}