aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Antunes2021-12-09 01:12:41 +0000
committerBruno Antunes2021-12-09 01:22:08 +0000
commit721d908fcd9200a752f165480ef16619ca32c91d (patch)
tree53e5bece982b37cb49a6545ccf4c237fdf4a9774
downloadaur-721d908fcd9200a752f165480ef16619ca32c91d.tar.gz
Initial release
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore4
-rw-r--r--LICENSE9
-rw-r--r--PKGBUILD46
-rw-r--r--icon.pngbin0 -> 10686 bytes
-rw-r--r--tailscale-systray.desktop8
6 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b16ca1c8b5bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = tailscale-systray-git
+ pkgdesc = Linux port of tailscale system tray menu.
+ pkgver = 20211209
+ pkgrel = 1
+ url = https://github.com/mattn/tailscale-systray
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ makedepends = git
+ makedepends = gcc
+ makedepends = gtk3
+ depends = tailscale
+ depends = libappindicator-gtk3
+ source = tailscale-systray.desktop
+ source = icon.png
+ source = LICENSE
+ source = git+https://github.com/mattn/tailscale-systray
+ sha256sums = a218407cfc354f3fa0844007aaac38c255e60a45aad09601208d73b03f3b7ebc
+ sha256sums = daffb052995411f5c25ac8977531bccb63a82d259817d4bd7808668fd4b5373c
+ sha256sums = d467163815d58e1aa199ffb6985cdc252b7c71fb454c5b6c5860498806c56670
+ sha256sums = SKIP
+
+pkgname = tailscale-systray-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..45ee9e0ecdc9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+tailscale-systray/
+tailscale-systray-git-*.pkg.tar.zst
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..ff47ff3d9acf
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,9 @@
+The MIT License (MIT)
+
+Copyright © 2021 Yasuhiro Matsumoto <mattn.jp@gmail.com>
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the “Software”), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf3b8bb730af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Bruno Antunes <sardaukar.siet@gmail.com>
+pkgname=tailscale-systray-git
+pkgver=20211209
+pkgrel=1
+pkgdesc='Linux port of tailscale system tray menu.'
+arch=('x86_64')
+url="https://github.com/mattn/tailscale-systray"
+license=('MIT')
+depends=('tailscale' 'libappindicator-gtk3')
+makedepends=('go' 'git' 'gcc' 'gtk3')
+source=( 'tailscale-systray.desktop'
+ 'icon.png'
+ 'LICENSE'
+ 'git+https://github.com/mattn/tailscale-systray')
+sha256sums=( 'a218407cfc354f3fa0844007aaac38c255e60a45aad09601208d73b03f3b7ebc'
+ 'daffb052995411f5c25ac8977531bccb63a82d259817d4bd7808668fd4b5373c'
+ 'd467163815d58e1aa199ffb6985cdc252b7c71fb454c5b6c5860498806c56670'
+ 'SKIP')
+
+_gitname=tailscale-systray
+
+build() {
+ cd "$srcdir/tailscale-systray"
+
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+
+ go build
+}
+
+package() {
+ cd "$srcdir/tailscale-systray"
+
+ mkdir -p $pkgdir/usr/bin
+ mkdir -p $pkgdir/usr/share/icons/tailscale-systray
+ mkdir -p $pkgdir/usr/share/licenses/tailscale-systray-git
+ mkdir -p $pkgdir/usr/share/applications
+
+ install -m755 $srcdir/tailscale-systray/tailscale-systray $pkgdir/usr/bin/tailscale-systray
+ install -m644 $srcdir/icon.png $pkgdir/usr/share/icons/tailscale-systray/icon.png
+ install -m644 $srcdir/LICENSE $pkgdir/usr/share/licenses/tailscale-systray-git/LICENSE
+ install -Dm644 $srcdir/tailscale-systray.desktop $pkgdir/usr/share/applications/tailscale-systray.desktop
+}
diff --git a/icon.png b/icon.png
new file mode 100644
index 000000000000..bfdaea7be855
--- /dev/null
+++ b/icon.png
Binary files differ
diff --git a/tailscale-systray.desktop b/tailscale-systray.desktop
new file mode 100644
index 000000000000..b47aa8db8f4d
--- /dev/null
+++ b/tailscale-systray.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Tailscale
+Exec=/usr/bin/tailscale-systray
+Type=Application
+StartupNotify=true
+Path=/usr/bin/tailscale-systray
+Icon=/usr/share/icons/tailscale-systray/icon.png
+StartupWMClass=tailscale-systray