summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Anderson2020-02-29 20:23:22 -0800
committerDavid Anderson2020-02-29 20:31:38 -0800
commit8b1af2f191b01d6c13a161c4bed111c22e48f61d (patch)
tree85959d56c27f4e2dbf8cdc0d8b7ba0fa9cdf65c8
downloadaur-8b1af2f191b01d6c13a161c4bed111c22e48f61d.tar.gz
Initial commit.
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore2
-rw-r--r--LICENSE27
-rw-r--r--PKGBUILD23
-rwxr-xr-xtailscale.install13
-rwxr-xr-xupdate.sh34
6 files changed, 114 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff0254127ef0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = tailscale-unstable-bin
+ pkgdesc = A mesh VPN that makes it easy to connect your devices, wherever they are.
+ pkgver = 0.95_388
+ pkgrel = 1
+ url = https://tailscale.com
+ install = tailscale.install
+ arch = x86_64
+ license = MIT
+ depends = glibc
+ backup = etc/default/tailscaled
+ source = tailscale-unstable-bin-0.95_388.tgz::https://pkgs.tailscale.com/unstable/tailscale_0.95-388_amd64.tgz
+ sha256sums = 4a6cc42123ee56c944e38337513f3d2806beebd4ef3e2c6abf5c6f5415af9d66
+
+pkgname = tailscale-unstable-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ca12330e9164
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.tgz
+*.pkg.tar.xz
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..eb7c3f6b2c72
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,27 @@
+Copyright (c) 2020 Tailscale & AUTHORS. All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are
+met:
+
+ * Redistributions of source code must retain the above copyright
+notice, this list of conditions and the following disclaimer.
+ * Redistributions in binary form must reproduce the above
+copyright notice, this list of conditions and the following disclaimer
+in the documentation and/or other materials provided with the
+distribution.
+ * Neither the name of Tailscale Inc. nor the names of its
+contributors may be used to endorse or promote products derived from
+this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e04f82f4979
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: David Anderson <dave@natulte.net>
+
+pkgname="tailscale-unstable-bin"
+_version="0.95-388"
+pkgver="0.95_388"
+pkgrel="1"
+pkgdesc="A mesh VPN that makes it easy to connect your devices, wherever they are."
+arch=("x86_64")
+url="https://tailscale.com"
+license=("MIT")
+depends=("glibc")
+backup=("etc/default/tailscaled")
+source=("$pkgname-$pkgver.tgz::https://pkgs.tailscale.com/unstable/tailscale_${_version}_amd64.tgz")
+sha256sums=('4a6cc42123ee56c944e38337513f3d2806beebd4ef3e2c6abf5c6f5415af9d66')
+install="tailscale.install"
+
+package() {
+ cd tailscale_${_version}_amd64
+ mkdir -p "$pkgdir/usr/bin" "$pkgdir/etc/default" "$pkgdir/usr/lib/systemd/system"
+ install -m755 tailscale tailscaled "$pkgdir/usr/bin"
+ install -m644 systemd/tailscaled.defaults "$pkgdir/etc/default/tailscaled"
+ install -m644 systemd/tailscaled.service "$pkgdir/usr/lib/systemd/system"
+}
diff --git a/tailscale.install b/tailscale.install
new file mode 100755
index 000000000000..8859a3a764aa
--- /dev/null
+++ b/tailscale.install
@@ -0,0 +1,13 @@
+# -*- mode: shell-script -*-
+
+post_install() {
+ echo -e "\n\e[1m Tailscale $1\e[0m\n"
+ cat <<EOF
+To start using Tailscale, start tailscaled and log in:
+
+ systemctl enable tailscaled
+ systemctl start tailscaled
+ tailscale up
+
+EOF
+}
diff --git a/update.sh b/update.sh
new file mode 100755
index 000000000000..41b98ecbe0f5
--- /dev/null
+++ b/update.sh
@@ -0,0 +1,34 @@
+#!/bin/bash
+
+set -euo pipefail
+
+tarball=$(curl https://pkgs.tailscale.com/unstable/ 2>/dev/null | grep amd64.tgz | cut -f2 -d'"')
+version=$(echo $tarball | cut -f2 -d'_')
+pkgver=$(echo $version | tr '-' '_')
+sha256=$(curl https://pkgs.tailscale.com/unstable/$tarball 2>/dev/null | sha256sum | cut -f1 -d' ')
+
+cat >PKGBUILD <<EOF
+# Maintainer: David Anderson <dave@natulte.net>
+
+pkgname="tailscale-unstable-bin"
+_version="$version"
+pkgver="$pkgver"
+pkgrel="1"
+pkgdesc="A mesh VPN that makes it easy to connect your devices, wherever they are."
+arch=("x86_64")
+url="https://tailscale.com"
+license=("MIT")
+depends=("glibc")
+backup=("etc/default/tailscaled")
+source=("\$pkgname-\$pkgver.tgz::https://pkgs.tailscale.com/unstable/tailscale_\${_version}_amd64.tgz")
+sha256sums=('$sha256')
+install="tailscale.install"
+
+package() {
+ cd tailscale_\${_version}_amd64
+ mkdir -p "\$pkgdir/usr/bin" "\$pkgdir/etc/default" "\$pkgdir/usr/lib/systemd/system"
+ install -m755 tailscale tailscaled "\$pkgdir/usr/bin"
+ install -m644 systemd/tailscaled.defaults "\$pkgdir/etc/default/tailscaled"
+ install -m644 systemd/tailscaled.service "\$pkgdir/usr/lib/systemd/system"
+}
+EOF