summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2015-11-06 22:14:18 +0100
committerCarsten Teibes2015-11-06 22:14:18 +0100
commit9b5a357b69a2487a41e7ebd43d484e889d8f850d (patch)
treed1535bf0671f99e099dd672c3474abd28ecedfc7
parenta2d3bba83781336070a7e54571db005cdcdef57c (diff)
downloadaur-9b5a357b69a2487a41e7ebd43d484e889d8f850d.tar.gz
[fix] dependencies, disable inlining with patch
Upstream commit used as patch: https://github.com/laochailan/taisei/commit/0f78b1a7eb05aa741541ca56559d7a3f381b57e2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
-rw-r--r--taisei-no-inlining.patch262
-rw-r--r--taisei.install1
4 files changed, 279 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e55548f49913..e4ed1dae081b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,24 @@
pkgbase = taisei
pkgdesc = Open source Touhou clone
pkgver = 1.0a
- pkgrel = 2
+ pkgrel = 3
url = http://taisei-project.org/
install = taisei.install
arch = i686
arch = x86_64
license = MIT
- makedepends = git
makedepends = cmake
+ makedepends = mesa
depends = sdl_ttf
depends = hicolor-icon-theme
- depends = mesa
+ depends = libgl
depends = libpng
depends = freealut
depends = glu
source = taisei-1.0a.tar.gz::https://github.com/laochailan/taisei/archive/v1.0a.tar.gz
+ source = taisei-no-inlining.patch
sha256sums = 1561c84c9fd8b9c7a91b864bdfc07fb811bb6da5c54cf32a2b6bd63de5f8f3ff
+ sha256sums = 2a39d4d9dbb0b8a3ab776ab24daa4ba29a97c739d2e74025bfd6b4149f8dc98c
pkgname = taisei
diff --git a/PKGBUILD b/PKGBUILD
index b8bc5bad2d59..b36c626662ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,24 @@
-# Maintainer: carstene1ns <url/mail: arch carsten-teibes de>
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
# Contributor: Lukas Weber <laochailan@web.de>
pkgname=taisei
pkgver=1.0a
-pkgrel=2
+pkgrel=3
pkgdesc="Open source Touhou clone"
arch=('i686' 'x86_64')
url="http://taisei-project.org/"
license=('MIT')
-depends=('sdl_ttf' 'hicolor-icon-theme' 'mesa' 'libpng' 'freealut' 'glu')
-makedepends=('git' 'cmake')
+depends=('sdl_ttf' 'hicolor-icon-theme' 'libgl' 'libpng' 'freealut' 'glu')
+makedepends=('cmake' 'mesa')
install=taisei.install
-source=($pkgname-$pkgver.tar.gz::"https://github.com/laochailan/taisei/archive/v$pkgver.tar.gz")
-sha256sums=('1561c84c9fd8b9c7a91b864bdfc07fb811bb6da5c54cf32a2b6bd63de5f8f3ff')
+source=($pkgname-$pkgver.tar.gz::"https://github.com/laochailan/taisei/archive/v$pkgver.tar.gz"
+ "$pkgname-no-inlining.patch")
+sha256sums=('1561c84c9fd8b9c7a91b864bdfc07fb811bb6da5c54cf32a2b6bd63de5f8f3ff'
+ '2a39d4d9dbb0b8a3ab776ab24daa4ba29a97c739d2e74025bfd6b4149f8dc98c')
+
+prepare() {
+ patch -d $pkgname-$pkgver -Np1 < $pkgname-no-inlining.patch
+}
build() {
cd $pkgname-$pkgver
diff --git a/taisei-no-inlining.patch b/taisei-no-inlining.patch
new file mode 100644
index 000000000000..0ac38b1421db
--- /dev/null
+++ b/taisei-no-inlining.patch
@@ -0,0 +1,262 @@
+From 0f78b1a7eb05aa741541ca56559d7a3f381b57e2 Mon Sep 17 00:00:00 2001
+From: "Andrew \"Akari\" Alexeyew" <akari@dbc.1gb.ua>
+Date: Fri, 10 Aug 2012 22:27:46 +0300
+Subject: [PATCH] Got rid of inline prototypes
+
+---
+ src/config.c | 8 ++++----
+ src/config.h | 8 ++++----
+ src/global.c | 8 ++++----
+ src/item.c | 2 +-
+ src/projectile.h | 2 +-
+ src/random.c | 16 ++++++++--------
+ src/random.h | 16 ++++++++--------
+ src/resource/model.c | 4 ++--
+ src/resource/texture.c | 2 +-
+ src/stageutils.c | 2 +-
+ src/stageutils.h | 2 +-
+ 11 files changed, 35 insertions(+), 35 deletions(-)
+
+diff --git a/src/config.c b/src/config.c
+index 5bdd3bd..650ca82 100644
+--- a/src/config.c
++++ b/src/config.c
+@@ -108,19 +108,19 @@ FILE* config_open(char *filename, char *mode) {
+ return out;
+ }
+
+-inline int config_intval_p(ConfigEntry *e) {
++int config_intval_p(ConfigEntry *e) {
+ return tconfig.intval[e->key];
+ }
+
+-inline char* config_strval_p(ConfigEntry *e) {
++char* config_strval_p(ConfigEntry *e) {
+ return tconfig.strval[e->key];
+ }
+
+-inline int config_intval(char *key) {
++int config_intval(char *key) {
+ return config_intval_p(config_findentry(key));
+ }
+
+-inline char* config_strval(char *key) {
++char* config_strval(char *key) {
+ return config_strval_p(config_findentry(key));
+ }
+
+diff --git a/src/config.h b/src/config.h
+index 483d288..ae8f8b1 100644
+--- a/src/config.h
++++ b/src/config.h
+@@ -77,9 +77,9 @@ void config_load(char *filename);
+ void config_save(char *filename);
+ ConfigEntry* config_findentry(char *name);
+
+-inline int config_intval(char*);
+-inline int config_intval_p(ConfigEntry*);
+-inline char* config_strval(char*);
+-inline char* config_strval_p(ConfigEntry*);
++int config_intval(char*);
++int config_intval_p(ConfigEntry*);
++char* config_strval(char*);
++char* config_strval_p(ConfigEntry*);
+
+ #endif
+diff --git a/src/global.c b/src/global.c
+index 4b20010..21fef1d 100644
+--- a/src/global.c
++++ b/src/global.c
+@@ -121,19 +121,19 @@ void fade_out(float f) {
+ colorfill(0, 0, 0, f);
+ }
+
+-inline double psin(double x) {
++double psin(double x) {
+ return 0.5 + 0.5 * sin(x);
+ }
+
+-inline double max(double a, double b) {
++double max(double a, double b) {
+ return (a > b)? a : b;
+ }
+
+-inline double min(double a, double b) {
++double min(double a, double b) {
+ return (a < b)? a : b;
+ }
+
+-inline double clamp(double f, double lower, double upper) {
++double clamp(double f, double lower, double upper) {
+ if(f < lower)
+ return lower;
+ if(f > upper)
+diff --git a/src/item.c b/src/item.c
+index fbeb54d..a3a31e5 100644
+--- a/src/item.c
++++ b/src/item.c
+@@ -126,7 +126,7 @@ int collision_item(Item *i) {
+ return 0;
+ }
+
+-inline void spawn_item(complex pos, Type type) {
++void spawn_item(complex pos, Type type) {
+ tsrand_fill(2);
+ create_item(pos, 5*cexp(I*tsrand_a(0)/afrand(1)*M_PI*2), type);
+ }
+diff --git a/src/projectile.h b/src/projectile.h
+index 16c9fd3..0aa6419 100644
+--- a/src/projectile.h
++++ b/src/projectile.h
+@@ -49,7 +49,7 @@ typedef struct Projectile {
+ } Projectile;
+
+ Color *rgba(float r, float g, float b, float a);
+-inline Color *rgb(float r, float g, float b);
++Color *rgb(float r, float g, float b);
+
+ #define create_particle3c(n,p,c,d,r,a1,a2,a3) create_particle4c(n,p,c,d,r,a1,a2,a3,0)
+ #define create_particle2c(n,p,c,d,r,a1,a2) create_particle4c(n,p,c,d,r,a1,a2,0,0)
+diff --git a/src/random.c b/src/random.c
+index ed917a6..26be952 100644
+--- a/src/random.c
++++ b/src/random.c
+@@ -33,19 +33,19 @@ int tsrand_p(RandomState *rnd) {
+ return (uint32_t)((rnd->z << 16u) + rnd->w) % TSRAND_MAX;
+ }
+
+-inline void tsrand_seed(uint32_t seed) {
++void tsrand_seed(uint32_t seed) {
+ tsrand_seed_p(tsrand_current, seed);
+ }
+
+-inline int tsrand(void) {
++int tsrand(void) {
+ return tsrand_p(tsrand_current);
+ }
+
+-inline double frand(void) {
++double frand(void) {
+ return tsrand()/(double)TSRAND_MAX;
+ }
+
+-inline double nfrand(void) {
++double nfrand(void) {
+ return frand() * 2 - 1;
+ }
+
+@@ -96,21 +96,21 @@ void tsrand_fill_p(RandomState *rnd, int amount) {
+ tsrand_array[i] = tsrand_p(rnd);
+ }
+
+-inline void tsrand_fill(int amount) {
++void tsrand_fill(int amount) {
+ tsrand_fill_p(tsrand_current, amount);
+ }
+
+-inline int tsrand_a(int idx) {
++int tsrand_a(int idx) {
+ if(idx >= tsrand_array_elems || idx < 0)
+ errx(-1, "tsrand_a: index out of range (%i / %i)", idx, tsrand_array_elems);
+ return tsrand_array[idx];
+ }
+
+-inline double afrand(int idx) {
++double afrand(int idx) {
+ return tsrand_a(idx)/(double)TSRAND_MAX;
+ }
+
+-inline double anfrand(int idx) {
++double anfrand(int idx) {
+ return afrand(idx) * 2 - 1;
+ }
+
+diff --git a/src/random.h b/src/random.h
+index 490e913..8f65db8 100644
+--- a/src/random.h
++++ b/src/random.h
+@@ -21,17 +21,17 @@ void tsrand_switch(RandomState *rnd);
+ void tsrand_seed_p(RandomState *rnd, uint32_t seed);
+ int tsrand_p(RandomState *rnd);
+
+-inline void tsrand_seed(uint32_t seed);
+-inline int tsrand(void);
++void tsrand_seed(uint32_t seed);
++int tsrand(void);
+
+-inline double frand(void);
+-inline double nfrand(void);
++double frand(void);
++double nfrand(void);
+
+ void tsrand_fill_p(RandomState *rnd, int amount);
+-inline void tsrand_fill(int amount);
+-inline int tsrand_a(int idx);
+-inline double afrand(int idx);
+-inline double anfrand(int idx);
++void tsrand_fill(int amount);
++int tsrand_a(int idx);
++double afrand(int idx);
++double anfrand(int idx);
+
+ #define TSRAND_MAX INT32_MAX
+
+diff --git a/src/resource/model.c b/src/resource/model.c
+index a560806..0245fb8 100644
+--- a/src/resource/model.c
++++ b/src/resource/model.c
+@@ -107,7 +107,7 @@ void parse_obj(char *filename, ObjFileData *data) {
+ }
+ }
+
+-static inline void bad_reference_error(char *filename, char *aux, int n) {
++static void bad_reference_error(char *filename, char *aux, int n) {
+ errx(-1, "load_model():\n!- OBJ file '%s': Index %d: bad %s index reference\n", filename, n, aux);
+ }
+
+@@ -227,4 +227,4 @@ void delete_model(void **models, void *model) {
+
+ void delete_models() { // Does not delete elements from the VBO, so doing this at runtime is leaking VBO space
+ delete_all_elements((void **)&resources.models, delete_model);
+-}
+\ No newline at end of file
++}
+diff --git a/src/resource/texture.c b/src/resource/texture.c
+index 2c30955..f4e85a3 100644
+--- a/src/resource/texture.c
++++ b/src/resource/texture.c
+@@ -25,7 +25,7 @@ Color *rgba(float r, float g, float b, float a) {
+ return clr;
+ }
+
+-inline Color *rgb(float r, float g, float b) {
++Color *rgb(float r, float g, float b) {
+ return rgba(r, g, b, 1.0);
+ }
+
+diff --git a/src/stageutils.c b/src/stageutils.c
+index 2edcef8..493aa08 100644
+--- a/src/stageutils.c
++++ b/src/stageutils.c
+@@ -34,7 +34,7 @@ void set_perspective_viewport(Stage3D *s, float n, float f, int vx, int vy, int
+ glMatrixMode(GL_MODELVIEW);
+ }
+
+-inline void set_perspective(Stage3D *s, float n, float f) {
++void set_perspective(Stage3D *s, float n, float f) {
+ set_perspective_viewport(s, n, f, VIEWPORT_X, VIEWPORT_Y, VIEWPORT_W, VIEWPORT_H);
+ }
+
+diff --git a/src/stageutils.h b/src/stageutils.h
+index 89ee1d8..e272ab6 100644
+--- a/src/stageutils.h
++++ b/src/stageutils.h
+@@ -39,7 +39,7 @@ void init_stage3d(Stage3D *s);
+ void add_model(Stage3D *s, SegmentDrawRule draw, SegmentPositionRule pos);
+
+ void set_perspective_viewport(Stage3D *s, float n, float f, int vx, int vy, int vw, int vh);
+-inline void set_perspective(Stage3D *s, float near, float far);
++void set_perspective(Stage3D *s, float near, float far);
+ void draw_stage3d(Stage3D *s, float maxrange);
+
+ void free_stage3d(Stage3D *s);
diff --git a/taisei.install b/taisei.install
index 3f676f0a189f..478b46b2b1ae 100644
--- a/taisei.install
+++ b/taisei.install
@@ -1,7 +1,6 @@
post_install() {
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
- update-desktop-database -q
}
post_upgrade() {