summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrei Alexeyev2018-01-26 21:04:47 +0200
committerAndrei Alexeyev2018-01-26 21:04:47 +0200
commitca43983959ab6bc96e87778bd0c6c29ffe149d98 (patch)
treed08d28125a191bb6e83e367ab0f4479120938694
parent56ba5cd8499d9b73cbc870c1f210bc55d8822874 (diff)
downloadaur-ca43983959ab6bc96e87778bd0c6c29ffe149d98.tar.gz
v1.2
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD17
2 files changed, 12 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4007111083a4..6998104d2311 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = taisei
pkgdesc = Open source Touhou clone
- pkgver = 1.1.2
+ pkgver = 1.2
pkgrel = 1
url = https://taisei-project.org/
arch = i686
arch = x86_64
license = MIT
- makedepends = cmake
+ makedepends = meson
+ makedepends = python-docutils
depends = sdl2_mixer
depends = sdl2_ttf
depends = libzip
depends = hicolor-icon-theme
- source = taisei-1.1.2.tar.gz::https://github.com/taisei-project/taisei/archive/v1.1.2.tar.gz
- sha256sums = 9b9ce2828a9c1fcc1de148e927c00b8bd541f891cae2df50552b9bba8f34122f
+ source = taisei-1.2.tar.gz::https://github.com/taisei-project/taisei/archive/v1.2.tar.gz
+ sha256sums = 8d2d682eeeb6284bc726b8ae52c355848b007957d2dc6bdd973f6384ae075ea3
pkgname = taisei
diff --git a/PKGBUILD b/PKGBUILD
index 3c9987c4f56c..caaff1ee5ecd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,31 +3,28 @@
# Contributor: Lukas Weber <laochailan@web.de>
pkgname=taisei
-pkgver=1.1.2
+pkgver=1.2
pkgrel=1
pkgdesc="Open source Touhou clone"
arch=('i686' 'x86_64')
url="https://taisei-project.org/"
license=('MIT')
depends=('sdl2_mixer' 'sdl2_ttf' 'libzip' 'hicolor-icon-theme')
-makedepends=('cmake')
+makedepends=('meson' 'python-docutils')
source=($pkgname-$pkgver.tar.gz::"https://github.com/taisei-project/taisei/archive/v$pkgver.tar.gz")
-sha256sums=('9b9ce2828a9c1fcc1de148e927c00b8bd541f891cae2df50552b9bba8f34122f')
+sha256sums=('8d2d682eeeb6284bc726b8ae52c355848b007957d2dc6bdd973f6384ae075ea3')
build() {
cd $pkgname-$pkgver
-
- cmake ./ \
- -DTAISEI_VERSION_OVERRIDE=$pkgver \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr
- make
+ arch-meson . build
+ ninja -C build
}
package() {
cd $pkgname-$pkgver
- make DESTDIR="$pkgdir/" install
+ DESTDIR="$pkgdir/" ninja -C build install
+
# license
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}