summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXichen Zhou2021-05-03 01:04:07 +0800
committerXichen Zhou2021-05-03 01:04:07 +0800
commit2e7b0daf669330e7d3d75fd9a5ea8b79f06dcd84 (patch)
treebb825bfa0af33bf2ad835fb1749e797c12fd5f97
downloadaur-2e7b0daf669330e7d3d75fd9a5ea8b79f06dcd84.tar.gz
version 0.3
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD45
2 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b070eb18c017
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+pkgbase = taiwins
+ pkgdesc = Tiling and floating wayland window manager focused on speed and size
+ pkgver = 0.3
+ pkgrel = 1
+ url = https://taiwins.org
+ arch = x86_64
+ license = GPL2
+ makedepends = meson
+ makedepends = ninja
+ makedepends = git
+ makedepends = wayland-protocols>=1.18
+ depends = glibc
+ depends = wayland>=1.17
+ depends = libxkbcommon
+ depends = libinput
+ depends = pixman>=0.25.0
+ depends = libdrm>=2.4.68
+ depends = pam
+ depends = systemd-libs
+ depends = dbus
+ depends = lua>=5.3.0
+ depends = libxcursor
+ depends = cairo
+ depends = fontconfig
+ depends = freetype2
+ depends = librsvg
+ depends = libgl
+ depends = libegl
+ depends = libgles
+ provides = taiwins
+ conflicts = taiwins
+ conflicts = taiwins-git
+ source = https://github.com/taiwins/taiwins/releases/download/v0.3/taiwins-0.3.tar.gz
+ source = https://github.com/taiwins/taiwins/releases/download/v0.3/taiwins-0.3.tar.gz.sig
+ validpgpkeys = A9C874AAE5654786A694114A041BB7CB35A212C3
+ md5sums = 1f55d0ee7cacb6cc18905c2df17a343a
+ md5sums = SKIP
+
+pkgname = taiwins
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e33b1c6544a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer Xichen Zhou <xzhou@xeechou.net>
+
+pkgname=taiwins
+_pkgname=taiwins
+pkgrel=1
+pkgver=0.3
+pkgdesc="Tiling and floating wayland window manager focused on speed and size"
+url="https://taiwins.org"
+license=('GPL2')
+source=("https://github.com/taiwins/taiwins/releases/download/v${pkgver}/${_pkgname}-${pkgver}.tar.gz"{,.sig})
+md5sums=('1f55d0ee7cacb6cc18905c2df17a343a' 'SKIP')
+arch=('x86_64')
+provides=('taiwins')
+conflicts=('taiwins' 'taiwins-git')
+
+depends=( 'glibc' 'wayland>=1.17' 'libxkbcommon' 'libinput' 'pixman>=0.25.0'
+ 'libdrm>=2.4.68' 'pam' 'systemd-libs' 'dbus' 'lua>=5.3.0' 'libxcursor'
+ 'cairo' 'fontconfig' 'freetype2' 'librsvg' 'libgl' 'libegl' 'libgles')
+
+validpgpkeys=('A9C874AAE5654786A694114A041BB7CB35A212C3') #xichen zhou
+
+makedepends=('meson' 'ninja' 'git' 'wayland-protocols>=1.18')
+
+prepare() {
+ cd $srcdir/${_pkgname}
+ meson --wrap-mode=nodownload --prefix /usr \
+ -Dbuildtype=release \
+ -Dxwayland=enabled \
+ -Dx11-backend=enabled \
+ -Dprofiler=disabled build
+}
+
+build() {
+ cd $srcdir/${_pkgname}
+ ninja -C build
+}
+
+package() {
+ cd $srcdir/${_pkgname}
+ DESTDIR=$pkgdir ninja -C build install
+ install -Dm644 $srcdir/${_pkgname}/subprojects/twclient/LICENSE "$pkgdir/usr/share/licenses/twclient/LICENSE"
+ install -Dm644 $srcdir/${_pkgname}/LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+}
+
+#vim: syntax=sh