summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxichen zhou2021-05-03 00:35:25 +0800
committerxichen zhou2021-05-03 00:35:25 +0800
commit64072b153c025709a284f076c14528bf42fa36b6 (patch)
treed8bcc50faba632a371acf054065947f6e86e8e23
parentf99cb672dfdf31f1a732d118be54dd20e06bf2f0 (diff)
downloadaur-taiwins-git.tar.gz
update to version 0.3
Signed-off-by: xichen zhou <xzhou@xeechou.net>
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD42
3 files changed, 48 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1222c0d99ae9..7d1a239f59b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = taiwins-git
pkgdesc = Tiling and floating wayland window manager focused on speed and size
- pkgver = 0.2.0
+ pkgver = v0.2.0.r434.gb98dd4b
pkgrel = 1
url = https://taiwins.org
arch = x86_64
@@ -27,8 +27,21 @@ pkgbase = taiwins-git
depends = libgl
depends = libegl
depends = libgles
- depends = wlroots=0.11.0
- source = git+http://github.com/taiwins/taiwins.git
+ source = git+https://github.com/taiwins/taiwins#tag=v0.3
+ source = git+https://github.com/taiwins/twclient#tag=v0.2
+ source = git+https://github.com/taiwins/twidgets#tag=v0.1
+ source = git+https://github.com/xeechou/ctypes#tag=v0.2
+ source = git+https://github.com/xeechou/tdbus#tag=v0.1
+ source = git+https://github.com/xeechou/love-nuklear#branch=nklua
+ source = git+https://github.com/Immediate-Mode-UI/Nuklear#commit=d829ff1
+ source = git+https://github.com/nothings/stb#commit=b42009b
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = SKIP
pkgname = taiwins-git
diff --git a/.gitignore b/.gitignore
index e9f30d2975da..8d1f2431daa0 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,3 @@
-pkg/*
-src/*
-taiwins/*
-*.pkg.tar.xz \ No newline at end of file
+*
+!PKGBUILD
+!.SRCINFO \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 18d9b88a1fd5..2dd9eab9acb8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,25 @@
pkgname=taiwins-git
_pkgname=taiwins
pkgrel=1
-pkgver=v0.2.0.r0.g5f1f4ea
+pkgver=v0.2.0.r434.gb98dd4b
pkgdesc="Tiling and floating wayland window manager focused on speed and size"
url="https://taiwins.org"
license=('GPL2')
-source=("git+https://github.com/${_pkgname}/${_pkgname}#tag=v0.2.0")
-md5sums=('SKIP')
+source=("git+https://github.com/${_pkgname}/${_pkgname}#tag=v0.3"
+ "git+https://github.com/${_pkgname}/twclient#tag=v0.2"
+ "git+https://github.com/${_pkgname}/twidgets#tag=v0.1"
+ "git+https://github.com/xeechou/ctypes#tag=v0.2"
+ "git+https://github.com/xeechou/tdbus#tag=v0.1"
+ "git+https://github.com/xeechou/love-nuklear#branch=nklua"
+ "git+https://github.com/Immediate-Mode-UI/Nuklear#commit=d829ff1"
+ "git+https://github.com/nothings/stb#commit=b42009b"
+ )
+md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
arch=('x86_64')
depends=( 'glibc' 'wayland>=1.17' 'libxkbcommon' 'libinput' 'pixman>=0.25.0'
'libdrm>=2.4.68' 'pam' 'systemd-libs' 'dbus' 'lua>=5.3.0' 'libxcursor'
- 'cairo' 'fontconfig' 'freetype2' 'librsvg' 'libgl' 'libegl' 'libgles'
- 'wlroots>=0.11.0')
+ 'cairo' 'fontconfig' 'freetype2' 'librsvg' 'libgl' 'libegl' 'libgles')
makedepends=('meson' 'ninja' 'git' 'wayland-protocols>=1.18')
@@ -24,15 +31,24 @@ pkgver() {
}
prepare() {
+
+ cd $srcdir/twclient
+ cp -r $srcdir/stb include
+
+ cd $srcdir/twidgets
+ rm -rf include/nklua
+ rm -rf include/twidgets/nuklear
+ cp -r $srcdir/love-nuklear include/nklua
+ cp -r $srcdir/Nuklear include/twidgets/nuklear
+
cd $srcdir/${_pkgname}
- git fetch origin --tag
- git submodule update --init --recursive
- if [ ! -d "subprojects/ctypes" ]; then
- meson wrap promote subprojects/twclient/subprojects/ctypes
- fi
- git submodule deinit subprojects/wlroots
- rm -rf subprojects/wlroots
- meson -Dbuildtype=release --prefix /usr build
+ git submodule init
+ cp -r $srcdir/twclient subprojects/
+ cp -r $srcdir/twidgets subprojects/
+ cp -r $srcdir/ctypes subprojects/
+ cp -r $srcdir/tdbus subprojects/
+
+ meson --wrap-mode=nodownload -Dbuildtype=release --prefix /usr build
}
build() {