summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxichen zhou2020-05-07 16:42:20 -0400
committerxichen zhou2020-05-07 16:42:20 -0400
commit1bd8bdf8f55e0ddd70b67db8c1defc06e9ac74fe (patch)
tree9931b40084bfd8144f18d3e13825a734c48ce346
downloadaur-1bd8bdf8f55e0ddd70b67db8c1defc06e9ac74fe.tar.gz
initial taiwins package
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD37
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9bc56d7916e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = taiwins-git
+ pkgdesc = Tiling and floating wayland window manager focused on speed and size
+ pkgver = 0.1.1
+ pkgrel = 0
+ url = https://www.taiwins.org
+ arch = x86_64
+ license = GPL2
+ depends = glibc
+ depends = wayland
+ depends = libxkbcommon
+ depends = libinput
+ depends = pixman
+ depends = libdrm
+ depends = pam
+ depends = systemd-libs
+ depends = dbus
+ depends = lua
+ depends = libxcursor
+ depends = cairo
+ depends = fontconfig
+ depends = freetype2
+ depends = librsvg
+ depends = xorg-server-xwayland
+ depends = libgl
+ depends = libegl
+ depends = libgles
+ source = git+http://github.com/taiwins/taiwins.git
+ md5sums = SKIP
+
+pkgname = taiwins-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b8360993364
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer Xichen Zhou <xzhou@xeechou.net>
+
+pkgname=taiwins-git
+_pkgname=taiwins
+pkgver=0.1.1
+pkgrel=0
+pkgdesc="Tiling and floating wayland window manager focused on speed and size"
+url="https://www.taiwins.org"
+license=('GPL2')
+source=("git+http://github.com/${_pkgname}/${_pkgname}.git")
+md5sums=('SKIP')
+arch=('x86_64')
+
+depends=( 'glibc' 'wayland' 'libxkbcommon' 'libinput' 'pixman' 'libdrm' 'pam'
+ 'systemd-libs' 'dbus' 'lua' 'libxcursor' 'cairo' 'fontconfig' 'freetype2'
+ 'librsvg' 'xorg-server-xwayland' 'libgl' 'libegl' 'libgles' )
+
+makedepedends=('cmake' 'git')
+
+prepare() {
+ cd $srcdir/${_pkgname}
+ git submodule update --init --recursive
+ cmake -S. -DCMAKE_INSTALL_PREFIX=/usr -Bbuild
+}
+
+build() {
+ cd $srcdir/${_pkgname}/build
+ make
+}
+
+package() {
+ cd $srcdir/${_pkgname}/build
+ make DESTDIR=$pkgdir install
+ install -Dm644 $srcdir/${_pkgname}/LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+}
+
+#vim: syntax=sh