summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgoreleaserbot2023-08-28 09:02:25 +0000
committergoreleaserbot2023-08-28 09:02:25 +0000
commitcbcfa9ce8c5a6bda160070864e2ec64a3161d63a (patch)
tree7a2ae0795291c2040d5131bbbe8b25f7534eaa92
parentcc46a4149ff7345a60abcff26d6b380b0d65accf (diff)
downloadaur-cbcfa9ce8c5a6bda160070864e2ec64a3161d63a.tar.gz
Update to v1.9.3
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 700597e5cfcf..2a85b2f6daff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = talhelper-bin
pkgdesc = A tool to help creating Talos cluster in GitOps way.
- pkgver = 1.9.2
+ pkgver = 1.9.3
pkgrel = 1
url = https://github.com/budimanjojo/talhelper
license = BSD-3-Clause
conflicts = talhelper
provides = talhelper
arch = aarch64
- source_aarch64 = https://github.com/budimanjojo/talhelper/releases/download/v1.9.2/talhelper_linux_arm64.tar.gz
- sha256sums_aarch64 = e1307efe3faca5ee695ba0ecf12110d3ff7223fdb4d290587c77a4e425da952b
+ source_aarch64 = https://github.com/budimanjojo/talhelper/releases/download/v1.9.3/talhelper_linux_arm64.tar.gz
+ sha256sums_aarch64 = b629f7f94422f669b5e5cc3c806d77cb1df74d8ba8bf7c33e84c2c8e3678a9b6
arch = x86_64
- source_x86_64 = https://github.com/budimanjojo/talhelper/releases/download/v1.9.2/talhelper_linux_amd64.tar.gz
- sha256sums_x86_64 = 369a171ab7df4ef88d18d239552d346487a3d51f2c0f75a37a94a6475d964811
+ source_x86_64 = https://github.com/budimanjojo/talhelper/releases/download/v1.9.3/talhelper_linux_amd64.tar.gz
+ sha256sums_x86_64 = 2dd5585041ea786aab31768273d0473e4639f7217d94dd8943c0400ab9757cf1
pkgname = talhelper-bin
diff --git a/PKGBUILD b/PKGBUILD
index 2113c217f2da..d5c412d30ffd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Budiman Jojo <budimanjojo at gmail dot com>
pkgname='talhelper-bin'
-pkgver=1.9.2
+pkgver=1.9.3
pkgrel=1
pkgdesc='A tool to help creating Talos cluster in GitOps way.'
url='https://github.com/budimanjojo/talhelper'
@@ -11,15 +11,19 @@ license=('BSD-3-Clause')
provides=('talhelper')
conflicts=('talhelper')
-source_aarch64=("${pkgname}_${pkgver}_aarch64.tar.gz::https://github.com/budimanjojo/talhelper/releases/download/v1.9.2/talhelper_linux_arm64.tar.gz")
-sha256sums_aarch64=('e1307efe3faca5ee695ba0ecf12110d3ff7223fdb4d290587c77a4e425da952b')
+source_aarch64=("${pkgname}_${pkgver}_aarch64.tar.gz::https://github.com/budimanjojo/talhelper/releases/download/v1.9.3/talhelper_linux_arm64.tar.gz")
+sha256sums_aarch64=('b629f7f94422f669b5e5cc3c806d77cb1df74d8ba8bf7c33e84c2c8e3678a9b6')
-source_x86_64=("${pkgname}_${pkgver}_x86_64.tar.gz::https://github.com/budimanjojo/talhelper/releases/download/v1.9.2/talhelper_linux_amd64.tar.gz")
-sha256sums_x86_64=('369a171ab7df4ef88d18d239552d346487a3d51f2c0f75a37a94a6475d964811')
+source_x86_64=("${pkgname}_${pkgver}_x86_64.tar.gz::https://github.com/budimanjojo/talhelper/releases/download/v1.9.3/talhelper_linux_amd64.tar.gz")
+sha256sums_x86_64=('2dd5585041ea786aab31768273d0473e4639f7217d94dd8943c0400ab9757cf1')
package() {
# bin
install -Dm755 "./talhelper" "${pkgdir}/usr/bin/talhelper"
# license
install -Dm644 "./LICENSE" "${pkgdir}/usr/share/licenses/talhelper/LICENSE"
+ # completions
+ "${pkgdir}/usr/bin/talhelper" completion bash | install -Dm644 /dev/stdin "${pkgdir}/usr/share/bash-completion/completions/talhelper"
+ "${pkgdir}/usr/bin/talhelper" completion fish | install -Dm644 /dev/stdin "${pkgdir}/usr/share/fish/completions/talhelper.fish"
+ "${pkgdir}/usr/bin/talhelper" completion zsh | install -Dm644 /dev/stdin "${pkgdir}/usr/share/zsh/site-functions/_talhelper"
}