summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDeposite Pirate2018-09-23 13:21:49 +0200
committerDeposite Pirate2018-09-23 13:21:49 +0200
commit57ecd57428cef59fcc61127fbe5cf1a1e9a6d448 (patch)
treef24beafd0c1a8702ca4e9e6f47de84a409703721
downloadaur-57ecd57428cef59fcc61127fbe5cf1a1e9a6d448.tar.gz
Initial commit.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD34
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff746b4784fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = talkatu-hg
+ pkgdesc = Gtk+ widgets for chat software
+ pkgver = r191.11dfbe8b2012
+ pkgrel = 1
+ url = https://bitbucket.org/pidgin/talkatu
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = mercurial
+ makedepends = meson
+ makedepends = help2man
+ depends = gtk3>=3.10.0
+ depends = glade>=2.0
+ depends = gumbo-parser>=0.10
+ depends = gspell>=1.2
+ depends = cmark
+ source = talkatu-hg::hg+https://bitbucket.org/pidgin/talkatu
+ sha256sums = SKIP
+
+pkgname = talkatu-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f03019902c4c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Deposite Pirate <dpirate at metalpunks dot info>
+#
+# Upstream: https://git.metalpunks.info/arch-ports
+
+_pkgname=talkatu
+pkgname=$_pkgname-hg
+pkgver=r191.11dfbe8b2012
+pkgrel=1
+pkgdesc="Gtk+ widgets for chat software"
+arch=('i686' 'x86_64')
+url="https://bitbucket.org/pidgin/talkatu"
+license=('GPL2')
+depends=('gtk3>=3.10.0' 'glade>=2.0' 'gumbo-parser>=0.10' 'gspell>=1.2' 'cmark')
+makedepends=('mercurial' 'meson' 'help2man')
+source=("$pkgname::hg+https://bitbucket.org/pidgin/$_pkgname")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" \
+ "$(hg identify -n)" \
+ "$(hg identify -i)"
+}
+
+build() {
+ cd "${pkgname}"
+ arch-meson build -Dtests=false
+ ninja -C build
+}
+
+package() {
+ cd "${pkgname}"
+ DESTDIR="${pkgdir}" ninja -C build install
+}