summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorerik-pro2019-01-26 22:12:54 +0300
committererik-pro2019-01-26 22:12:54 +0300
commit5839cb5cfe3c57ceac6a040647955be8c4c56e43 (patch)
treeebaf108ce191fdd1a649b10aae0faa2d195cb6f5
parent7126b3779c0939e88c28811381cb4e205a85ce2c (diff)
downloadaur-5839cb5cfe3c57ceac6a040647955be8c4c56e43.tar.gz
changed upstream
updated pkgver
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD30
2 files changed, 18 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0949d116e54..fa2ad353dba9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = talkingarch-git
pkgdesc = Builds TalkingArch, an unofficial Arch Linux live CD with speech and braille support added
- pkgver = 20150501
+ pkgver = v1.r13.1f99984
pkgrel = 1
- url = http://talkingarch.tk/
- arch = any
+ url = https://talkingarch.info/
+ arch = x86_64
license = GPL
makedepends = git
makedepends = sox
@@ -11,7 +11,7 @@ pkgbase = talkingarch-git
depends = archiso-git
provides = talkingarch
conflicts = talkingarch
- source = git+https://notabug.org/talkingarch/talkingarch.git
+ source = git+https://github.com/erik-pro/talkingarch.git
md5sums = SKIP
pkgname = talkingarch-git
diff --git a/PKGBUILD b/PKGBUILD
index fbd8808b9e9c..3dcf256d6848 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,29 @@
-# Maintainer: Kelly Prescott <kprescott@coolip.net>
+# Maintainer: erik-pro <aarnaarn2@gmail.com>
+# Contributor: Kelly Prescott <kprescott@coolip.net>
# Contributor: Kyle <kyle@gmx.ca>
# Contributor: Chris Brannon <cmbrannon79@gmail.com>
+
pkgname=talkingarch-git
-_gitname=talkingarch
-pkgver=20150501
+pkgver=1.1.r0.g1f99984
pkgrel=1
pkgdesc="Builds TalkingArch, an unofficial Arch Linux live CD with speech and braille support added"
-arch=('any')
-url="http://talkingarch.tk/"
+arch=('x86_64')
+url="https://talkingarch.info/"
license=('GPL')
depends=(archiso-git)
-# I don't want folks using archiso from extra, since it's old.
makedepends=(git sox opus-tools)
provides=(talkingarch)
conflicts=(talkingarch)
-source=(git+https://notabug.org/talkingarch/talkingarch.git)
+source=(git+https://github.com/erik-pro/talkingarch.git)
md5sums=('SKIP')
-#pkgver() {
-# cd $_gitname
-# # Use the tag of the last commit
-# git describe --always | sed -e 's|v||' -e 's|-|.|g'
-#}
+pkgver() {
+ cd talkingarch
+ # cutting off 'v' prefix that presents in the git tag
+ printf "%s" "$(git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g')"
+}
package() {
- cd "${_gitname}"
- make DESTDIR="$pkgdir" install
+ cd talkingarch
+ make DESTDIR="$pkgdir" install
}
-
-# vim:set ts=2 sw=2 et: