summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKelly Prescott2015-07-19 22:54:03 -0500
committerKelly Prescott2015-07-19 22:54:03 -0500
commit7126b3779c0939e88c28811381cb4e205a85ce2c (patch)
tree08a2816fe23459920936f2f8f5291fbe0ec1951a
downloadaur-7126b3779c0939e88c28811381cb4e205a85ce2c.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0949d116e54
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = talkingarch-git
+ pkgdesc = Builds TalkingArch, an unofficial Arch Linux live CD with speech and braille support added
+ pkgver = 20150501
+ pkgrel = 1
+ url = http://talkingarch.tk/
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = sox
+ makedepends = opus-tools
+ depends = archiso-git
+ provides = talkingarch
+ conflicts = talkingarch
+ source = git+https://notabug.org/talkingarch/talkingarch.git
+ md5sums = SKIP
+
+pkgname = talkingarch-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fbd8808b9e9c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Kelly Prescott <kprescott@coolip.net>
+# Contributor: Kyle <kyle@gmx.ca>
+# Contributor: Chris Brannon <cmbrannon79@gmail.com>
+pkgname=talkingarch-git
+_gitname=talkingarch
+pkgver=20150501
+pkgrel=1
+pkgdesc="Builds TalkingArch, an unofficial Arch Linux live CD with speech and braille support added"
+arch=('any')
+url="http://talkingarch.tk/"
+license=('GPL')
+depends=(archiso-git)
+# I don't want folks using archiso from extra, since it's old.
+makedepends=(git sox opus-tools)
+provides=(talkingarch)
+conflicts=(talkingarch)
+source=(git+https://notabug.org/talkingarch/talkingarch.git)
+md5sums=('SKIP')
+
+#pkgver() {
+# cd $_gitname
+# # Use the tag of the last commit
+# git describe --always | sed -e 's|v||' -e 's|-|.|g'
+#}
+
+package() {
+ cd "${_gitname}"
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: