summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornano132017-12-07 15:25:45 +0100
committernano132017-12-07 15:25:45 +0100
commit6ecb03c25e936581899df4958411f3a9981bca0b (patch)
treec9d443db55324a11bab42f07193dc06f434dc38e
parent51dbb42b33cbac92b88ddf81bdd8d400ebdfcd06 (diff)
downloadaur-6ecb03c25e936581899df4958411f3a9981bca0b.tar.gz
added handling new cpp gui
-rw-r--r--PKGBUILD16
-rw-r--r--tambi-cpp.sh7
2 files changed, 19 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b4f489dbe173..ee5b0c4f2a75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,18 @@
_pkgname=('tambi')
pkgname=('tambi-git')
-pkgver=598
+pkgver=660
pkgrel=1
pkgdesc='A swiss army knife for studiing the bible and much more'
arch=('any')
licence=('undecided')
url='https://github.com/nano13/tambi.git'
makedepends=('git' 'python-setuptools')
-depends=('python3' 'python-pyqt5' 'qt5-charts' 'python-pyqtchart' 'python-pysword' 'python-markdown' 'python-gpsd-git' 'python-geopy' 'python-srtm-git' 'python-pillow')
+depends=('pythonqt' 'python3' 'python-pyqt5' 'qt5-charts' 'python-pyqtchart' 'python-pysword' 'python-markdown' 'python-gpsd-git' 'python-geopy' 'python-srtm-git' 'python-pillow')
source=(${_pkgname}::git+https://github.com/nano13/tambi.git
- $_pkgname.sh)
-sha256sums=('SKIP' 'SKIP')
+ $_pkgname.sh
+ $_pkgname-cpp.sh)
+sha256sums=('SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -22,6 +23,12 @@ pkgver() {
package() {
cd "$srcdir"/"$_pkgname"
+ # compile tambi.cpp
+ cd c++
+ qmake-qt5 -o Makefile tambi.pro
+ make
+
+ cd ..
# putting the freedesktop .desktop file and the program icon to the right place
mkdir -p "$pkgdir"/usr/share/applications
mkdir -p "$pkgdir"/usr/share/pixmaps
@@ -33,4 +40,5 @@ package() {
#install -dm577 "$pkgdir"/usr/share/$pkgname/
install -Dm755 "$srcdir"/$_pkgname.sh "$pkgdir"/usr/bin/$_pkgname
+ install -Dm755 "$srcdir"/$_pkgname-cpp.sh "$pkgdir"/usr/bin/$_pkgname-cpp.sh
}
diff --git a/tambi-cpp.sh b/tambi-cpp.sh
new file mode 100644
index 000000000000..f378e81f063d
--- /dev/null
+++ b/tambi-cpp.sh
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+cd /usr/share/tambi-git/c++
+
+./tambi
+
+exit