summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornano132017-12-07 15:28:36 +0100
committernano132017-12-07 15:28:36 +0100
commitd5448f3f938478e492328f2c2cfd0b89fadd3339 (patch)
tree531fa74777ed5d2c024a0e6c3498cdec750f059f
parent6ecb03c25e936581899df4958411f3a9981bca0b (diff)
parent5eab7dc894f28f0ec82afcb660fd966a5988aba0 (diff)
downloadaur-d5448f3f938478e492328f2c2cfd0b89fadd3339.tar.gz
Merge branch 'master' of ssh://aur.archlinux.org/tambi-git
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d320c994a299..59fa712ad8fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tambi-git
- pkgdesc = A swiss army knife for studiing the bible and much more
- pkgver = 598
+ pkgdesc = A swiss army knife for studying the bible and much more
+ pkgver = 613
pkgrel = 1
url = https://github.com/nano13/tambi.git
arch = any
@@ -16,6 +16,7 @@ pkgbase = tambi-git
depends = python-geopy
depends = python-srtm-git
depends = python-pillow
+ depends = python-whoosh
source = tambi::git+https://github.com/nano13/tambi.git
source = tambi.sh
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index ee5b0c4f2a75..816b5426f0eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,15 @@ _pkgname=('tambi')
pkgname=('tambi-git')
pkgver=660
pkgrel=1
-pkgdesc='A swiss army knife for studiing the bible and much more'
+pkgdesc='A swiss army knife for studying the bible and much more'
arch=('any')
licence=('undecided')
url='https://github.com/nano13/tambi.git'
makedepends=('git' 'python-setuptools')
depends=('pythonqt' 'python3' 'python-pyqt5' 'qt5-charts' 'python-pyqtchart' 'python-pysword' 'python-markdown' 'python-gpsd-git' 'python-geopy' 'python-srtm-git' 'python-pillow')
source=(${_pkgname}::git+https://github.com/nano13/tambi.git
- $_pkgname.sh
- $_pkgname-cpp.sh)
-sha256sums=('SKIP' 'SKIP' 'SKIP')
+ $_pkgname.sh)
+sha256sums=('SKIP' 'SKIP')
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -23,6 +22,9 @@ pkgver() {
package() {
cd "$srcdir"/"$_pkgname"
+ # initialize submodules
+ git submodule update --init --recursive
+
# compile tambi.cpp
cd c++
qmake-qt5 -o Makefile tambi.pro