summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Witschel2020-01-20 14:56:36 +0100
committerJonas Witschel2020-01-20 14:56:36 +0100
commit1954bb02b25d6bcf71a3d38c87c2006c3b578516 (patch)
tree4a448007177ca60e8b619e972743860cfa9c036f
parent237f3d802e994bf528c3128deb8f6ee1dcaa6379 (diff)
downloadaur-1954bb02b25d6bcf71a3d38c87c2006c3b578516.tar.gz
upgpkg: tang-git 7.r2.fed9020-1
Upstream switched their build system to meson.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD18
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e3d2a8e6a86..2de8f60b30c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = tang-git
pkgdesc = Server for binding data to network presence
- pkgver = 7.r1.00fc856
- pkgrel = 2
+ pkgver = 7.r2.fed9020
+ pkgrel = 1
url = https://github.com/latchset/tang
arch = x86_64
license = GPL3
makedepends = git
makedepends = asciidoc
+ makedepends = meson
depends = http-parser
depends = jose
provides = tang
diff --git a/PKGBUILD b/PKGBUILD
index 6085fcdbfb9b..704fb5a62954 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Jonas Witschel <diabonas@archlinux.org>
pkgname=tang-git
-pkgver=7.r1.00fc856
-pkgrel=2
+pkgver=7.r2.fed9020
+pkgrel=1
pkgdesc='Server for binding data to network presence'
arch=('x86_64')
url='https://github.com/latchset/tang'
license=('GPL3')
depends=('http-parser' 'jose')
-makedepends=('git' 'asciidoc')
+makedepends=('git' 'asciidoc' 'meson')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=("git+$url.git")
@@ -20,21 +20,23 @@ pkgver() {
prepare() {
cd "${pkgname%-git}"
- autoreconf --install --force
+ # Use -Wformat in addition to -Wformat-security in add_project_arguments
+ # (https://github.com/latchset/tang/pull/41)
+ git cherry-pick --no-commit ceaaa98e91f9d2aaf89090f624ed969ab21c505a
}
build() {
cd "${pkgname%-git}"
- ./configure --prefix=/usr --libexecdir=/usr/lib --localstatedir=/var
- make
+ meson --libexecdir=/usr/lib --buildtype=plain build
+ ninja -C build
}
check() {
cd "${pkgname%-git}"
- make check
+ ninja -C build test
}
package() {
cd "${pkgname%-git}"
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" ninja -C build install
}