summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkirill2018-01-20 02:05:21 +0300
committerkirill2018-01-20 02:05:21 +0300
commit58387c2baeefa6e75d676b17f00d8189998a8da3 (patch)
tree46dbc63ba4eae69da8e2747df81c0f7a1ae4c6b8
downloadaur-58387c2baeefa6e75d676b17f00d8189998a8da3.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD41
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..164a487afa80
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Fri Jan 19 22:06:58 UTC 2018
+pkgbase = tango
+ pkgdesc = Tango Controls a toolkit for controlling any kind of hardware or software and building SCADA systems
+ pkgver = 9.2.5a
+ pkgrel = 1
+ url = http://www.tango-controls.org/
+ arch = i686
+ arch = x86_64
+ license = GPLv3
+ depends = mysql56
+ depends = doxygen
+ depends = zeromq
+ depends = omniorb
+ depends = jdk8-openjdk
+ depends = jre8-openjdk
+ depends = binutils
+ source = tango-9.2.5a.tar.gz::https://netix.dl.sourceforge.net/project/tango-cs/tango-9.2.5a.tar.gz
+ md5sums = db8bb308ac2304090b93636c5462fd0e
+
+pkgname = tango
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c98396962306
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Kirill A Pshenichnyi <pshcyrill@mail.ru>
+# Contributors: The Tango team (info@tango-controls.org)
+
+pkgname=tango
+pkgver=9.2.5a
+pkgrel=1
+pkgdesc="Tango Controls a toolkit for controlling any kind of hardware or software and building SCADA systems"
+arch=('i686' 'x86_64')
+url="http://www.tango-controls.org/"
+license=('GPLv3')
+depends=('mysql56' 'doxygen' 'zeromq' 'omniorb' 'jdk8-openjdk' 'jre8-openjdk' 'binutils')
+conflicts=('')
+source=("tango-$pkgver.tar.gz::https://netix.dl.sourceforge.net/project/tango-cs/tango-$pkgver.tar.gz")
+md5sums=('db8bb308ac2304090b93636c5462fd0e')
+
+
+build() {
+ cd "$pkgname-$pkgver"
+ read -r -p "will you enter the mysql host, admin and password now, or create the .my.cnf file yourself? [y/n]: " yn
+ if [[ "$yn" =~ ^(y|Y|yes|Yes)$ ]]
+ then
+ read -r -p "MySQL host: " mysql_host
+ read -r -p "MySQL admin: " mysql_admin
+ read -s -r -p "MySQL password: " mysql_password
+ echo ''
+ ./configure --prefix=/usr --with-mysql-ho=$mysql_host --with-mysql-admin=$mysql_admin --with-mysql-admin-passwd=$mysql_password
+ else
+ ./configure --prefix=/usr
+ fi
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}