summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteffen Weber2016-05-13 12:17:47 +0200
committerSteffen Weber2016-05-13 12:17:47 +0200
commit2d69b4d6e18f2678f2133ed00febdece40ccf18b (patch)
tree2430fc5aceddad5f1efa93d779422fdeca46489e
parente05ce336f4a128c8cc4dbbdbc2e5621ddb62891c (diff)
downloadaur-2d69b4d6e18f2678f2133ed00febdece40ccf18b.tar.gz
Update to 0.8.0-10
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
-rw-r--r--rsvg.patch61
3 files changed, 56 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3af22529f5f2..249c8b0a4f0a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,26 @@
+# Generated by mksrcinfo v8
+# Fri May 13 10:16:43 UTC 2016
pkgbase = tango-icon-theme
pkgdesc = Icon theme that follows the Tango visual guidelines
pkgver = 0.8.90
- pkgrel = 9
- url = http://tango.freedesktop.org
+ pkgrel = 10
+ url = http://tango-project.org
arch = any
license = custom:public domain
license = custom:TRADEMARKS
makedepends = imagemagick
makedepends = icon-naming-utils
makedepends = intltool
- makedepends = librsvg
options = !strip
options = !zipman
- source = http://tango.freedesktop.org/releases/tango-icon-theme-0.8.90.tar.bz2
+ source = http://http.debian.net/debian/pool/main/t/tango-icon-theme/tango-icon-theme_0.8.90.orig.tar.gz
source = http://cinderwick.ca/files/archlinux/artwork-official/symbol.svg
source = http://cinderwick.ca/files/archlinux/licensing-docs/TRADEMARKS
source = rsvg.patch
- md5sums = b7b9b16480afb781a4c13f8bceb8688b
+ md5sums = 0795895d2f20eddcbd2bffe94ed431a6
md5sums = e9c0c2e165f2883c3fa00277635ae4ae
md5sums = 05066419eb8239652a0467131485db4d
- md5sums = 46f86ad43d793cd5389a7bd9c58a57ae
+ md5sums = 40cb8a4dd485bac0851c6fd2915d43ba
pkgname = tango-icon-theme
diff --git a/PKGBUILD b/PKGBUILD
index c89e2b389c07..7fd67efd7e3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,25 +4,25 @@
pkgname=tango-icon-theme
pkgver=0.8.90
-pkgrel=9
+pkgrel=10
pkgdesc="Icon theme that follows the Tango visual guidelines"
arch=('any')
-url="http://tango.freedesktop.org"
+url="http://tango-project.org"
license=('custom:public domain' 'custom:TRADEMARKS')
-makedepends=('imagemagick' 'icon-naming-utils' 'intltool' 'librsvg')
+makedepends=('imagemagick' 'icon-naming-utils' 'intltool')
options=(!strip !zipman)
-source=(${url}/releases/${pkgname}-${pkgver}.tar.bz2
+source=(http://http.debian.net/debian/pool/main/t/${pkgname}/${pkgname}_${pkgver}.orig.tar.gz
http://cinderwick.ca/files/archlinux/artwork-official/symbol.svg
http://cinderwick.ca/files/archlinux/licensing-docs/TRADEMARKS
rsvg.patch)
-md5sums=('b7b9b16480afb781a4c13f8bceb8688b'
+md5sums=('0795895d2f20eddcbd2bffe94ed431a6'
'e9c0c2e165f2883c3fa00277635ae4ae'
'05066419eb8239652a0467131485db4d'
- '46f86ad43d793cd5389a7bd9c58a57ae')
+ '40cb8a4dd485bac0851c6fd2915d43ba')
prepare() {
cd ${pkgname}-${pkgver}
- patch -p1 < "${srcdir}/rsvg.patch"
+ patch -p0 < "${srcdir}/rsvg.patch"
autoreconf -fi
}
@@ -51,8 +51,8 @@ package() {
for size in 16 22 24 32 48 64 72 96 128; do
# replace default logo with Arch Linux's
- rsvg-convert -w ${size} -h ${size} "${srcdir}/symbol.svg" \
- -o "${size}x${size}/places/start-here.png"
+ convert -background none "${srcdir}/symbol.svg" -resize ${size}x${size} \
+ "${size}x${size}/places/start-here.png"
# create icon for category "Education"
ln -s "../status/dialog-information.png" \
"${size}x${size}/categories/applications-science.png"
@@ -71,4 +71,4 @@ package() {
"scalable/places/start-here.svg"
ln -s "../status/dialog-information.svg" \
"scalable/categories/applications-science.svg"
-} \ No newline at end of file
+}
diff --git a/rsvg.patch b/rsvg.patch
index 6b71c38cb0f2..514f73795eb8 100644
--- a/rsvg.patch
+++ b/rsvg.patch
@@ -1,34 +1,51 @@
-Index: tango-icon-theme-0.8.90/configure.ac
-===================================================================
---- tango-icon-theme-0.8.90.orig/configure.ac
-+++ tango-icon-theme-0.8.90/configure.ac
-@@ -82,7 +82,7 @@ if test "x$enable_large_bitmaps" = "xyes
- PKG_CHECK_EXISTS([librsvg-2.0 >= 2.12.3],
+--- configure.ac 2009-02-26 04:06:20.000000000 +0100
++++ configure.ac.patched 2016-01-30 11:24:14.906672000 +0100
+@@ -69,7 +69,7 @@
+ fi
+ fi
+
+-# Check for rsvg or ksvgtopng for creating large scale bitmaps from svg
++# Check for imagemagick for creating large scale bitmaps from svg
+ AC_ARG_ENABLE(png-creation,
+ AC_HELP_STRING([--enable-png-creation],
+ [enable creating png images from svg [default=disabled]]),
+@@ -79,17 +79,13 @@
+ SVGCONVERT=""
+ AC_MSG_CHECKING([SVG to PNG conversion method])
+ if test "x$enable_large_bitmaps" = "xyes"; then
+- PKG_CHECK_EXISTS([librsvg-2.0 >= 2.12.3],
++ PKG_CHECK_EXISTS([imagemagick],
[enable_large_bitmaps=yes], [enable_large_bitmaps=no])
- if test "x$enable_large_bitmaps" = "xyes"; then
+- if test "x$enable_large_bitmaps" = "xyes"; then
- svgconvert_prog="rsvg"
-+ svgconvert_prog="rsvg-convert"
+- else
+- svgconvert_prog="ksvgtopng"
+- fi
++ svgconvert_prog="convert"
+ AC_MSG_RESULT([$svgconvert_prog])
+ AC_PATH_PROG(SVGCONVERT, $svgconvert_prog)
+ if test -z "$SVGCONVERT"; then
+- AC_MSG_ERROR([You need librsvg >= 2.12.3 or ksvgtopng installed to create large scale bitmaps])
++ AC_MSG_ERROR([You need imagemagick installed to create large scale bitmaps])
else
- svgconvert_prog="ksvgtopng"
+ enable_large_bitmaps=yes
fi
-Index: tango-icon-theme-0.8.90/svg2png.sh.in
-===================================================================
---- tango-icon-theme-0.8.90.orig/svg2png.sh.in
-+++ tango-icon-theme-0.8.90/svg2png.sh.in
-@@ -9,12 +9,14 @@ fi
+--- svg2png.sh.in 2007-02-16 21:04:29.000000000 +0100
++++ svg2png.sh.in.patched 2016-01-30 11:30:53.446678000 +0100
+@@ -9,12 +9,9 @@
ICONFILE=`basename ${3}`
ICONNAME=`echo ${ICONFILE} | sed -e "s/.svg//"`
-if test `basename $SVGCONVERT` = "rsvg"; then
-+if test `basename $SVGCONVERT` = "rsvg-convert"; then
- OPTIONS="-w ${1} -h ${1}"
-+ OUTPUT="-o"
- else
- OPTIONS="${1} ${1}"
-+ OUTPUT=""
- fi
+- OPTIONS="-w ${1} -h ${1}"
+-else
+- OPTIONS="${1} ${1}"
+-fi
++OPTIONS="-background none"
++OUTPUT="-resize ${1}x${1}"
- echo "${SVGCONVERT} ${OPTIONS} ${3} ${2}/${ICONNAME}.png"
+-echo "${SVGCONVERT} ${OPTIONS} ${3} ${2}/${ICONNAME}.png"
-${SVGCONVERT} ${OPTIONS} ${3} ${2}/${ICONNAME}.png
++echo "${SVGCONVERT} ${OPTIONS} ${3} ${OUTPUT} ${2}/${ICONNAME}.png"
+${SVGCONVERT} ${OPTIONS} ${3} ${OUTPUT} ${2}/${ICONNAME}.png