summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-10-25 10:56:31 -0600
committerMark Wagie2021-10-25 10:56:31 -0600
commit6093e91c0c7c341306cbe91888dd2110bd01b5bb (patch)
treedc74d3174478f1208bed8e8c2f42055ef03d0fee
parentbac11d45c280d2cff1ea33673cb00797a745130e (diff)
downloadaur-6093e91c0c7c341306cbe91888dd2110bd01b5bb.tar.gz
fix build with Meson 0.60.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea9f13edae38..97077a86f203 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tangram
pkgdesc = Run web apps on your desktop.
- pkgver = 1.3.1
- pkgrel = 2
+ pkgver = 1.3.1+5+g8934dcd
+ pkgrel = 1
url = https://apps.gnome.org/app/re.sonny.Tangram
arch = any
license = GPL3
@@ -14,7 +14,7 @@ pkgbase = tangram
conflicts = gigagram
conflicts = tangram-web
replaces = tangram-web
- source = tangram::git+https://github.com/sonnyp/Tangram.git#tag=v1.3.1
+ source = tangram::git+https://github.com/sonnyp/Tangram.git#commit=8934dcdb3ab43a04e2a210ec508c97c338a72ffe
source = git+https://github.com/sonnyp/troll.git
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 9364a19673f7..8eb9174a9d1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: Sonny Piers <sonny at fastmail dot net>
pkgname=tangram
-pkgver=1.3.1
-pkgrel=2
+pkgver=1.3.1+5+g8934dcd
+pkgrel=1
pkgdesc="Run web apps on your desktop."
arch=('any')
url="https://apps.gnome.org/app/re.sonny.Tangram"
@@ -12,11 +12,18 @@ conflicts=('gigagram' "$pkgname-web")
replaces=("$pkgname-web")
makedepends=('git' 'npm' 'meson')
#checkdepends=('appstream-glib')
-source=("${pkgname%-web}::git+https://github.com/sonnyp/Tangram.git#tag=v$pkgver"
+_commit=8934dcdb3ab43a04e2a210ec508c97c338a72ffe
+source=("${pkgname%-web}::git+https://github.com/sonnyp/Tangram.git#commit=$_commit"
+#source=("${pkgname%-web}::git+https://github.com/sonnyp/Tangram.git#tag=v$pkgver"
'git+https://github.com/sonnyp/troll.git')
sha256sums=('SKIP'
'SKIP')
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --tags | sed 's/^v//;s/-/+/g'
+}
+
prepare() {
cd "$srcdir/$pkgname"
git submodule init