summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2017-01-21 22:34:02 +0330
committerMohammadreza Abdollahzadeh2017-01-21 22:34:02 +0330
commitca6ec2585505e207b174f83b85f34c16d7ae63f0 (patch)
tree608ae44f3fa860ee1a212c53d4c28d15acacb6f7
downloadaur-ca6ec2585505e207b174f83b85f34c16d7ae63f0.tar.gz
Initial Import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD25
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9355b0d2dd9d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sat Jan 21 19:03:53 UTC 2017
+pkgbase = tanha-fonts
+ pkgdesc = A beautiful Persian font based on Samim and Vazir font.
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = https://rastikerdar.github.io/tanha-font/
+ arch = any
+ license = OFL
+ depends = fontconfig
+ provides = ttf-tanha
+ provides = tanha-fonts
+ conflicts = ttf-tanha
+ conflicts = tanha-fonts
+ replaces = ttf-tanha
+ source = tanha-fonts-0.4.1.zip::https://github.com/rastikerdar/tanha-font/archive/master.zip
+ sha256sums = 3b24be7503a86637565f9caf818d39d5f959bd1277049c0cd28ea3a874738e9e
+
+pkgname = tanha-fonts
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c5683bac152
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id$
+# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+
+pkgname=tanha-fonts
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="A beautiful Persian font based on Samim and Vazir font."
+url="https://rastikerdar.github.io/tanha-font/"
+arch=(any)
+license=('OFL')
+depends=('fontconfig')
+provides=('ttf-tanha' "$pkgname")
+conflicts=('ttf-tanha' "$pkgname")
+replaces=('ttf-tanha')
+source=("$pkgname-$pkgver.zip::https://github.com/rastikerdar/tanha-font/archive/master.zip")
+sha256sums=('3b24be7503a86637565f9caf818d39d5f959bd1277049c0cd28ea3a874738e9e')
+
+package() {
+ cd tanha-font-master
+ install -d "$pkgdir/usr/share/fonts/${pkgname%-fonts}"
+ install -t "$pkgdir/usr/share/fonts/${pkgname%-fonts}" -m644 ./dist/Tanha.{eot,ttf,woff}
+ install -Dm644 ./LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: