summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsh0rez2020-04-07 21:23:50 +0200
committersh0rez2020-04-07 21:27:35 +0200
commit1dbc37ae8d378bdc806a1a6b8db8cae9bc814e95 (patch)
treee32543e9d8fb60a81f95e912ce834c66ee8866ef
parentdb381bd3d1f364dda597cfaa09c2d8359dd2ff1b (diff)
downloadaur-1dbc37ae8d378bdc806a1a6b8db8cae9bc814e95.tar.gz
bump 0.9.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD18
2 files changed, 24 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fff54041a030..77cd6cc2371d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,17 @@
pkgbase = tanka-bin
- pkgdesc = Flexible, reusable and concise configuration for Kubernetes
- pkgver = 0.8.0
+ pkgdesc = Flexible, reusable and concise configuration for Kubernetes using Jsonnet
+ pkgver = 0.9.0
pkgrel = 0
- url = https://github.com/grafana/tanka
+ url = https://tanka.dev
arch = x86_64
license = Apache
- source = https://github.com/grafana/tanka/releases/download/v0.8.0/tk-linux-amd64
- sha256sums = b122aa39b3e6090d82559284fe2bb7a36463fa02e254bccc40be205ebef34740
+ depends = diffutils
+ depends = kubectl
+ optdepends = jsonnet-bundler-bin: jsonnet package manager
+ provides = tanka
+ conflicts = tanka
+ source = https://github.com/grafana/tanka/releases/download/v0.9.0/tk-linux-amd64
+ sha256sums = ca27aae3e45f261135001911f5a349df4b3652268e67904159a679a89c9bbaa5
pkgname = tanka-bin
diff --git a/PKGBUILD b/PKGBUILD
index be24918c5835..86c2f9f48609 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,24 @@
# Maintainer: sh0rez <me@shorez.de>
pkgname=tanka-bin
-pkgver=0.8.0
+pkgver=0.9.0
pkgrel=0
-pkgdesc="Flexible, reusable and concise configuration for Kubernetes"
+pkgdesc="Flexible, reusable and concise configuration for Kubernetes using Jsonnet"
arch=('x86_64')
-url="https://github.com/grafana/tanka"
+
+url="https://tanka.dev"
license=('Apache')
source=("https://github.com/grafana/tanka/releases/download/v${pkgver}/tk-linux-amd64")
-sha256sums=('b122aa39b3e6090d82559284fe2bb7a36463fa02e254bccc40be205ebef34740')
+
+depends=('diffutils' 'kubectl')
+optdepends=(
+ 'jsonnet-bundler-bin: jsonnet package manager'
+)
+
+provides=(tanka)
+conflicts=(tanka)
+
+sha256sums=('ca27aae3e45f261135001911f5a349df4b3652268e67904159a679a89c9bbaa5')
package() {
install -Dm 755 "$srcdir/tk-linux-amd64" "$pkgdir/usr/bin/tk"