summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDuologic2020-06-26 09:19:12 +0200
committerDuologic2020-06-26 09:19:12 +0200
commit4a239e0ef4c0b1b61fe781c9f93ed76a94050ea3 (patch)
tree51d93d0fff32dfa0c620457237b0916f5096c245
downloadaur-4a239e0ef4c0b1b61fe781c9f93ed76a94050ea3.tar.gz
initial
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD41
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ad791d6ed19
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = tanka-git
+ pkgdesc = Flexible, reusable and concise configuration for Kubernetes using Jsonnet
+ pkgver = v0.10.0.r11.g62b18e4
+ pkgrel = 0
+ url = https://tanka.dev
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = aarch64
+ license = Apache
+ makedepends = git
+ makedepends = go
+ depends = diffutils
+ depends = kubectl
+ optdepends = jsonnet-bundler-bin: jsonnet package manager
+ provides = tanka
+ conflicts = tanka-bin
+ source = git+https://github.com/grafana/tanka.git
+ md5sums = SKIP
+
+pkgname = tanka-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a7f4bc3db79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Duologic <jeroen@simplsitic.be>
+# Maintainer: sh0rez <me@shorez.de>
+
+pkgname=tanka-git
+pkgver=v0.10.0.r11.g62b18e4
+pkgrel=0
+pkgdesc="Flexible, reusable and concise configuration for Kubernetes using Jsonnet"
+arch=('i686' 'x86_64' 'arm' 'aarch64')
+
+url="https://tanka.dev"
+license=('Apache')
+source=("git+https://github.com/grafana/tanka.git")
+
+makedepends=('git' 'go')
+depends=('diffutils' 'kubectl')
+optdepends=(
+ 'jsonnet-bundler-bin: jsonnet package manager'
+)
+
+provides=(tanka)
+conflicts=(tanka-bin)
+
+md5sums=('SKIP')
+
+function pkgver() {
+ cd "$srcdir/tanka"
+ (
+ set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "$srcdir/tanka"
+ make static
+}
+
+package() {
+ install -Dm755 "$srcdir/tanka/tk" -t "$pkgdir/usr/bin"
+}