summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortimdubbins2023-09-21 16:42:42 +0100
committertimdubbins2023-09-21 16:42:42 +0100
commit5d04d35c0eb189062045073c5140c6fbad4527fe (patch)
treefce3a61a4f008dacafafb498c16bd6857c29d0b4
parent985188daa978ad098a003960515238b526a98b2e (diff)
downloadaur-5d04d35c0eb189062045073c5140c6fbad4527fe.tar.gz
bump to v0.4.5
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
2 files changed, 21 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1808f473e596..18b339e9ee36 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
-pkgbase = tap
+pkgbase = tap-bin
pkgdesc = An audio player for the terminal with fuzzy-finder
- pkgver = 0.4.4
+ pkgver = 0.4.5
pkgrel = 1
url = https://github.com/timdubbins/tap
arch = x86_64
- license = MIT
- makedepends = cargo
- depends = gcc-libs
- source = tap-0.4.4.tar.gz::https://github.com/timdubbins/tap/archive/v0.4.4.tar.gz
- sha256sums = 588a7051ed716247a3f915f1a94e280a9e0627e42046bda32458006311d7f02f
+ license = Unlicense OR MIT
+ provides = tap
+ conflicts = tap
+ source = https://github.com/timdubbins/tap/releases/download/v0.4.5/tap-0.4.5-x86_64.tar.gz
+ sha256sums = 5f673c8012b7a6f5685f073caa0edcdf43260711d84f3765832c5b741ab49788
-pkgname = tap
+pkgname = tap-bin
diff --git a/PKGBUILD b/PKGBUILD
index cb9972f5bd47..0e8e05512962 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,20 @@
# Maintainer: Tim Dubbins <timdubbins@gmail.com>
-pkgname=tap
-pkgver=0.4.4
+#
+# This PKGBUILD was generated by `cargo aur`: https://crates.io/crates/cargo-aur
+
+pkgname=tap-bin
+pkgver=0.4.5
pkgrel=1
pkgdesc="An audio player for the terminal with fuzzy-finder"
-arch=('x86_64')
url="https://github.com/timdubbins/tap"
-license=('MIT')
-depends=('gcc-libs')
-makedepends=('cargo')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/timdubbins/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('588a7051ed716247a3f915f1a94e280a9e0627e42046bda32458006311d7f02f')
-
-
-prepare() {
- cd "$pkgname-$pkgver"
- export RUSTUP_TOOLCHAIN=stable
- cargo fetch --target "$CARCH-unknown-linux-gnu"
-}
-
-build() {
- cd "$pkgname-$pkgver"
- export RUSTUP_TOOLCHAIN=stable
- export CARGO_TARGET_DIR=target
- cargo build --frozen --release --all-features
-}
+license=("Unlicense OR MIT")
+arch=("x86_64")
+provides=("tap")
+conflicts=("tap")
+source=("https://github.com/timdubbins/tap/releases/download/v$pkgver/tap-$pkgver-x86_64.tar.gz")
+sha256sums=("5f673c8012b7a6f5685f073caa0edcdf43260711d84f3765832c5b741ab49788")
package() {
- cd "$pkgname-$pkgver"
- install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$pkgname"
+ install -Dm755 tap -t "$pkgdir/usr/bin"
+ install -Dm644 LICENSE-MIT "$pkgdir/usr/share/licenses/$pkgname/LICENSE-MIT"
}