summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormakepkg2020-07-26 16:05:32 +0200
committermakepkg2020-07-26 16:05:32 +0200
commitfd00d1e67756ce0c70de7d86445050fa379d1bc9 (patch)
tree17dfe75bff209b4545bcfa53f2752ce3b2ac71cc
parentc419ce31915a875776b3d5e6102e48b36809b271 (diff)
downloadaur-tapecalc.tar.gz
Added a `epoch=0` and a stub to remove from $pkgver the leading `t` in upstreams package version. The stub is commented out, since https://wiki.archlinux.org/index.php/Arch_package_guidelines#Package_versioning suggests that the letter is indeed to be kept if upstream has it, but in case that it should be removed it is easy to do it.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3e450c10dd6..87ebffa8d46d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = tapecalc
pkgdesc = Fixed-point calculator as a fullscreen editor. You may edit at any position in the expression list. Supports basic arithmetic, interest and sales tax computation. Designed for use as a checkbook or expense-account balancing tool. Formerly known as 'add'.
- pkgver = 20180401
- pkgrel = 1
- epoch = 1
+ pkgver = t20180401
+ pkgrel = 3
+ epoch = 0
url = http://invisible-island.net/add/add.html
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 0cf23cf5f1f6..ea6327aebee9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,9 @@
_pkgname=tapecalc
pkgname="${_pkgname}"
-epoch=1
-pkgver=20180401
-pkgrel=1
+epoch=0
+pkgver=t20180401
+pkgrel=3
pkgdesc="Fixed-point calculator as a fullscreen editor. You may edit at any position in the expression list. Supports basic arithmetic, interest and sales tax computation. Designed for use as a checkbook or expense-account balancing tool. Formerly known as 'add'."
url="http://invisible-island.net/add/add.html"
@@ -70,7 +70,7 @@ pkgver() {
# Or we can extract it from the makefile.in, which is consistent with what would end up in the executable:
cd "$(_latestdir "${srcdir}")"
- grep -E '^[[:space:]]*RELEASE[[:space:]]*=.*[0-9]+' makefile.in | cut -d= -f2 | tr -d '[[:space:]]' | sed -E 's|^t||'
+ grep -E '^[[:space:]]*RELEASE[[:space:]]*=.*[0-9]+' makefile.in | cut -d= -f2 | tr -d '[[:space:]]' # | sed -E 's|^t||'
}