summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelics2018-06-29 13:36:56 +0200
committerfelics2018-06-29 13:36:56 +0200
commited01df668843e2a6e715916ab2945fabad40524c (patch)
tree2a12491e352a5dabd39cbabd45ba5f62e78572a8
downloadaur-ed01df668843e2a6e715916ab2945fabad40524c.tar.gz
Initial Commit
-rw-r--r--.SRCINFO16
-rw-r--r--COPYING3
-rw-r--r--PKGBUILD45
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a89e76c9763
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = tapecalc-add-compat
+ pkgdesc = Provides compatibility: Makes 'tapecalc' available also under it's original name 'add'.
+ pkgver = t20180401
+ pkgrel = 1
+ url = http://aur.archlinux.org/packages/tapecalc/
+ arch = any
+ license = custom: public domain.
+ depends = tapecalc=t20180401
+ provides = add=t20180401
+ conflicts = add
+ options = emptydirs
+ source = COPYING
+ sha256sums = 90d77bbbe6aa2cfdaf6eaa3580fd1a981e0d0428ae586ac37b47aee5e67fcf12
+
+pkgname = tapecalc-add-compat
+
diff --git a/COPYING b/COPYING
new file mode 100644
index 000000000000..202cbb93e23b
--- /dev/null
+++ b/COPYING
@@ -0,0 +1,3 @@
+This simple symlink-and-metapackage is public domain.
+
+The real software this package depends on and symlinks may have another license, please check!
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7df084ddf835
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+#!/bin/bash
+
+# Maintainer: dreieck
+
+pkgname=tapecalc-add-compat
+pkgver=t20180401
+pkgrel=1
+
+pkgdesc="Provides compatibility: Makes 'tapecalc' available also under it's original name 'add'."
+url="http://aur.archlinux.org/packages/tapecalc/"
+license=('custom: public domain.')
+
+arch=(
+ 'any'
+)
+
+depends=(
+ "tapecalc=${pkgver}"
+)
+makedepends=()
+optdepends=()
+provides=(
+ "add=${pkgver}"
+)
+replaces=()
+conflicts=(
+ "add"
+)
+
+options=('emptydirs')
+
+source=(
+ 'COPYING'
+)
+sha256sums=(
+ '90d77bbbe6aa2cfdaf6eaa3580fd1a981e0d0428ae586ac37b47aee5e67fcf12'
+)
+
+package() {
+ install -v -d -m755 "${pkgdir}/usr/bin"
+ cd "${pkgdir}/usr/bin"
+ ln -sv "tapecalc" "add"
+
+ install -v -D -m644 "${srcdir}/COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}